summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Rob van Nues <sborg63@disroot.org>2019-09-08 07:27:03 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-09-08 07:27:03 +0700
commita34fc7ba46c1425877dc0676b6485ad3a70e5cc8 (patch)
tree29284ae76d545f97b48bde50c019967b0dab8a13 /python
parentdacb1fedc8f7f2ccce7873d1c85a0a412a00e962 (diff)
downloadslackbuilds-a34fc7ba46c1425877dc0676b6485ad3a70e5cc8.tar.gz
slackbuilds-a34fc7ba46c1425877dc0676b6485ad3a70e5cc8.tar.xz
python/ruffus: Updated for version 2.8.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/ruffus/ruffus.SlackBuild15
-rw-r--r--python/ruffus/ruffus.info8
2 files changed, 16 insertions, 7 deletions
diff --git a/python/ruffus/ruffus.SlackBuild b/python/ruffus/ruffus.SlackBuild
index e82481cd28..e237bbf541 100644
--- a/python/ruffus/ruffus.SlackBuild
+++ b/python/ruffus/ruffus.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ruffus
-# Copyright 2018 Rob van Nues
+# Copyright 2018-2019 Rob van Nues
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ruffus
-VERSION=${VERSION:-2.8.1}
+VERSION=${VERSION:-2.8.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+#set which python version to install it for
+PYTHON2=false
+PYTHON3=true
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -69,7 +73,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+if $PYTHON2; then
+ python setup.py install --root=$PKG
+fi
+if $PYTHON3; then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/ruffus/ruffus.info b/python/ruffus/ruffus.info
index 71c5d98b1a..afb01e2389 100644
--- a/python/ruffus/ruffus.info
+++ b/python/ruffus/ruffus.info
@@ -1,10 +1,10 @@
PRGNAM="ruffus"
-VERSION="2.8.1"
+VERSION="2.8.3"
HOMEPAGE="http://www.ruffus.org.uk"
-DOWNLOAD="https://files.pythonhosted.org/packages/18/24/05e8fe590d08bd9e6122c6a87425ff741c79edf01d2873f92028e860e547/ruffus-2.8.1.tar.gz"
-MD5SUM="9a500473b1394d0da085708efc617382"
+DOWNLOAD="https://files.pythonhosted.org/packages/a1/73/cc66b80cfd495d6ce1e26292776d8f6bb67281bde4f47826b6cb20aa9c87/ruffus-2.8.3.tar.gz"
+MD5SUM="4fece047fb945e4b6a96bec7d9fad450"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Rob van Nues"
EMAIL="sborg63@disroot.org"