summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2011-03-29 23:48:35 +0200
committer Robby Workman <rworkman@slackbuilds.org>2011-03-30 22:52:57 -0500
commitb3aa4eb3f28db2e140cbd780dda877a54b70dcc8 (patch)
treeb17f838ac27377fcfdc32abc97c34c355ed48cf2 /python
parent1acb78077679edcf2a22abea82fa9e96375e2da4 (diff)
downloadslackbuilds-b3aa4eb3f28db2e140cbd780dda877a54b70dcc8.tar.gz
slackbuilds-b3aa4eb3f28db2e140cbd780dda877a54b70dcc8.tar.xz
python/pyparsing: Moved from /development and updated for version 1.5.5
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyparsing/README5
-rw-r--r--python/pyparsing/pyparsing.SlackBuild86
-rw-r--r--python/pyparsing/pyparsing.info10
-rw-r--r--python/pyparsing/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/pyparsing/README b/python/pyparsing/README
new file mode 100644
index 0000000000..ac29972273
--- /dev/null
+++ b/python/pyparsing/README
@@ -0,0 +1,5 @@
+The pyparsing module is an alternative approach to creating and
+executing simple grammars, vs. the traditional lex/yacc
+approach, or the use of regular expressions. The pyparsing
+module provides a library of classes that client code uses to
+construct the grammar directly in Python code.
diff --git a/python/pyparsing/pyparsing.SlackBuild b/python/pyparsing/pyparsing.SlackBuild
new file mode 100644
index 0000000000..43320ce5b3
--- /dev/null
+++ b/python/pyparsing/pyparsing.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for pyparsing
+
+# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyparsing
+VERSION=1.5.5
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE PKG-INFO README HowToUsePyparsing.html \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyparsing/pyparsing.info b/python/pyparsing/pyparsing.info
new file mode 100644
index 0000000000..1b1bf4b378
--- /dev/null
+++ b/python/pyparsing/pyparsing.info
@@ -0,0 +1,10 @@
+PRGNAM="pyparsing"
+VERSION="1.5.5"
+HOMEPAGE="http://pyparsing.wikispaces.com/"
+DOWNLOAD="http://downloads.sourceforge.net/pyparsing/pyparsing-1.5.5.tar.gz"
+MD5SUM="0beba391cba3082d7914c289bffa52ce"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@liwjatan.at"
+APPROVED="dsomero"
diff --git a/python/pyparsing/slack-desc b/python/pyparsing/slack-desc
new file mode 100644
index 0000000000..53c17d5249
--- /dev/null
+++ b/python/pyparsing/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------|
+pyparsing: pyparsing (parsing module for python)
+pyparsing:
+pyparsing: The pyparsing module is an alternative approach to creating and
+pyparsing: executing simple grammars, vs. the traditional lex/yacc
+pyparsing: approach, or the use of regular expressions. The pyparsing
+pyparsing: module provides a library of classes that client code uses to
+pyparsing: construct the grammar directly in Python code.
+pyparsing:
+pyparsing: Homepage: http://pyparsing.wikispaces.com/
+pyparsing:
+pyparsing: