summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy [AT] linuxleo.com>2016-08-26 21:54:18 +0100
committer David Spencer <idlemoor@slackbuilds.org>2016-08-28 00:22:59 +0100
commitbb41500b29f880051c9aaf3c1c7a8ca8da62c5c1 (patch)
tree6c30ea0433f5d40c2cde71dd27c0449b87eb9fa5 /python
parentac468a03b27a8ab8559f5b0fe7f3a9ba8d47e198 (diff)
downloadslackbuilds-bb41500b29f880051c9aaf3c1c7a8ca8da62c5c1.tar.gz
slackbuilds-bb41500b29f880051c9aaf3c1c7a8ca8da62c5c1.tar.xz
python/dfdatetime: Added (Digital Forensics Date and Time).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/dfdatetime/README7
-rw-r--r--python/dfdatetime/dfdatetime.SlackBuild86
-rw-r--r--python/dfdatetime/dfdatetime.info10
-rw-r--r--python/dfdatetime/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/dfdatetime/README b/python/dfdatetime/README
new file mode 100644
index 0000000000..98970816c4
--- /dev/null
+++ b/python/dfdatetime/README
@@ -0,0 +1,7 @@
+dfdatetime (Python library for Digital Forensics Date and Time)
+
+dfDateTime, or Digital Forensics date and time, provides date and time objects
+to preserve accuracy and precision.
+
+dfDateTime is part of the log2timeline project:
+https://github.com/log2timeline
diff --git a/python/dfdatetime/dfdatetime.SlackBuild b/python/dfdatetime/dfdatetime.SlackBuild
new file mode 100644
index 0000000000..895aaffe64
--- /dev/null
+++ b/python/dfdatetime/dfdatetime.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for dfdatetime
+# Copyright 2016 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# New submission v20160323 August 2016, Barry J. Grundy.
+
+PRGNAM=dfdatetime
+VERSION=${VERSION:-20160323}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/"$PRGNAM"-$VERSION.tar.gz
+cd "$PRGNAM"-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README LICENSE AUTHORS PKG-INFO ACKNOWLEDGEMENTS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/dfdatetime/dfdatetime.info b/python/dfdatetime/dfdatetime.info
new file mode 100644
index 0000000000..37ecba4423
--- /dev/null
+++ b/python/dfdatetime/dfdatetime.info
@@ -0,0 +1,10 @@
+PRGNAM="dfdatetime"
+VERSION="20160323"
+HOMEPAGE="https://github.com/log2timeline/dfdatetime"
+DOWNLOAD="https://github.com/log2timeline/dfdatetime/releases/download/20160323/dfdatetime-20160323.tar.gz"
+MD5SUM="ccb655d901346b50aafb39c54e312c2c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/dfdatetime/slack-desc b/python/dfdatetime/slack-desc
new file mode 100644
index 0000000000..7ebcae183e
--- /dev/null
+++ b/python/dfdatetime/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dfdatetime: dfdatetime (Python library for Digital Forensics Date and Time)
+dfdatetime:
+dfdatetime: dfdatetime provides date and time objects to preserver accuracy and
+dfdatetime: precision.
+dfdatetime:
+dfdatetime: Homepage: https://github.com/log2timeline/dfdatetime
+dfdatetime:
+dfdatetime:
+dfdatetime:
+dfdatetime:
+dfdatetime: