summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2012-06-25 21:47:03 -0400
committer dsomero <xgizzmo@slackbuilds.org>2012-06-25 21:47:03 -0400
commitc20d8940b59e899e01ccfb4efaa872a7cb7e668b (patch)
treeea0bfacf5257a9602e3e4938d6f2253fa5f130e2 /python
parentf5cd53de2b4f3b391b7e5a5dc089c2de53401c4f (diff)
downloadslackbuilds-c20d8940b59e899e01ccfb4efaa872a7cb7e668b.tar.gz
slackbuilds-c20d8940b59e899e01ccfb4efaa872a7cb7e668b.tar.xz
python/pyutil: Updated for version 1.9.3.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyutil/pyutil.SlackBuild15
-rw-r--r--python/pyutil/pyutil.info6
-rw-r--r--python/pyutil/slack-desc2
3 files changed, 10 insertions, 13 deletions
diff --git a/python/pyutil/pyutil.SlackBuild b/python/pyutil/pyutil.SlackBuild
index 019464af50..708f82de8b 100644
--- a/python/pyutil/pyutil.SlackBuild
+++ b/python/pyutil/pyutil.SlackBuild
@@ -27,16 +27,14 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=pyutil
-VERSION=${VERSION:-1.8.4}
+VERSION=${VERSION:-1.9.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -46,8 +44,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="COPYING.GPL COPYING.TGPPL.html README.rst"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
@@ -71,14 +67,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.GPL COPYING.TGPPL.html README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
#cleanup
diff --git a/python/pyutil/pyutil.info b/python/pyutil/pyutil.info
index 6e274ea20a..668d0ff2a5 100644
--- a/python/pyutil/pyutil.info
+++ b/python/pyutil/pyutil.info
@@ -1,8 +1,8 @@
PRGNAM="pyutil"
-VERSION="1.8.4"
+VERSION="1.9.3"
HOMEPAGE="http://pypi.python.org/pypi/pyutil"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pyutil/pyutil-1.8.4.tar.gz"
-MD5SUM="1eb14efa6184208a204a39e8e03d7354"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pyutil/pyutil-1.9.3.tar.gz"
+MD5SUM="3902a6ad6772eebc347cfcca41d1b63f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Markus Reichelt"
diff --git a/python/pyutil/slack-desc b/python/pyutil/slack-desc
index 9120dd4881..7603049e4e 100644
--- a/python/pyutil/slack-desc
+++ b/python/pyutil/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler----------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
pyutil: pyutil (Python utilities)
pyutil:
pyutil: A collection of functions and data structures from allmydata.org