summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-06-07 05:12:01 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-09 05:33:15 +0700
commitcacbae7fb85aa0dab99fa5528a5c38d5795f2eec (patch)
treebac3870115b05c7447d66f8450b2634dda640be6 /python
parent2eb7c71f9075964c1eefe196c4d124b4cfc76777 (diff)
downloadslackbuilds-cacbae7fb85aa0dab99fa5528a5c38d5795f2eec.tar.gz
slackbuilds-cacbae7fb85aa0dab99fa5528a5c38d5795f2eec.tar.xz
python/simplegeneric: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/simplegeneric/simplegeneric.SlackBuild19
-rw-r--r--python/simplegeneric/simplegeneric.info2
2 files changed, 12 insertions, 9 deletions
diff --git a/python/simplegeneric/simplegeneric.SlackBuild b/python/simplegeneric/simplegeneric.SlackBuild
index b3fe69b8fc..1d05a64c72 100644
--- a/python/simplegeneric/simplegeneric.SlackBuild
+++ b/python/simplegeneric/simplegeneric.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for simplegeneric
# Copyright 2012 Mikko Värri, Finland
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=simplegeneric
VERSION=${VERSION:-0.8.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,15 +51,18 @@ unzip $CWD/$PRGNAM-$VERSION.zip
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/simplegeneric/simplegeneric.info b/python/simplegeneric/simplegeneric.info
index 44923a3330..2060b0aa93 100644
--- a/python/simplegeneric/simplegeneric.info
+++ b/python/simplegeneric/simplegeneric.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://pypi.python.org/packages/source/s/simplegeneric/simplegeneric-
MD5SUM="f9c1fab00fd981be588fc32759f474e3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"