summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Tim Dickson <dickson.tim@googlmail.com>2018-11-02 22:32:09 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:46:44 +0700
commitcd9e10dcd57f7d72b665cc5ce1e13e6a22ae689a (patch)
tree5d1b63d5f9343b538d9f23c6daf86dd6f4507271 /python
parent46456e7effc2564a241cd4b89c93893cca4c2b8d (diff)
downloadslackbuilds-cd9e10dcd57f7d72b665cc5ce1e13e6a22ae689a.tar.gz
slackbuilds-cd9e10dcd57f7d72b665cc5ce1e13e6a22ae689a.tar.xz
python/python3-docutils: Added (Python Document Utilities module).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-docutils/README6
-rw-r--r--python/python3-docutils/python3-docutils.SlackBuild73
-rw-r--r--python/python3-docutils/python3-docutils.info10
-rw-r--r--python/python3-docutils/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/python3-docutils/README b/python/python3-docutils/README
new file mode 100644
index 0000000000..638cc644d3
--- /dev/null
+++ b/python/python3-docutils/README
@@ -0,0 +1,6 @@
+Python3-Docutils (Python Documentation Utilities)
+
+Docutils is a modular system for processing documentation into useful
+formats, such as HTML, XML, and LaTeX. For input Docutils supports
+reStructuredText, an easy-to-read, what-you-see-is-what-you-get plaintext
+markup syntax. This provides python3 support.
diff --git a/python/python3-docutils/python3-docutils.SlackBuild b/python/python3-docutils/python3-docutils.SlackBuild
new file mode 100644
index 0000000000..f3f2346825
--- /dev/null
+++ b/python/python3-docutils/python3-docutils.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for docutils
+
+# Copyright 2006-2018 Robby Workman Tuscaloosa, AL, USA
+# modified for python3, copyright 2018 Tim Dickson, Scotland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-docutils
+SRCPRGNAM=docutils
+VERSION=${VERSION:-0.14}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCPRGNAM-$VERSION
+tar xvf $CWD/$SRCPRGNAM-$VERSION.tar.gz
+cd $SRCPRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-docutils/python3-docutils.info b/python/python3-docutils/python3-docutils.info
new file mode 100644
index 0000000000..e5e11f968f
--- /dev/null
+++ b/python/python3-docutils/python3-docutils.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-docutils"
+VERSION="0.14"
+HOMEPAGE="http://docutils.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/docutils/docutils-0.14.tar.gz"
+MD5SUM="c53768d63db3873b7d452833553469de"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Tim Dickson"
+EMAIL="dickson.tim@googlmail.com"
diff --git a/python/python3-docutils/slack-desc b/python/python3-docutils/slack-desc
new file mode 100644
index 0000000000..b3e21ae1ee
--- /dev/null
+++ b/python/python3-docutils/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-docutils: python3-docutils (Python Document Utilities module)
+python3-docutils:
+python3-docutils: Docutils is an open-source text processing system for processing
+python3-docutils: plaintext documentation into useful formats, such as HTML or LaTeX.
+python3-docutils: It includes reStructuredText, the easy to read, easy to use,
+python3-docutils: what-you-see-is-what-you-get plaintext markup language.
+python3-docutils:
+python3-docutils: Homepage: http://docutils.sourceforge.net/
+python3-docutils:
+python3-docutils:
+python3-docutils: