summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-10 19:09:53 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-13 07:22:19 +0700
commitfdd52e899b3421fe650c900ca73c181011eb2bc2 (patch)
tree7cf49a43575f8ca3a0c4535b75286cadb76842f5 /python
parentcf83be6d3cb72f3499925a4dadc4e2e0d3437e93 (diff)
downloadslackbuilds-fdd52e899b3421fe650c900ca73c181011eb2bc2.tar.gz
slackbuilds-fdd52e899b3421fe650c900ca73c181011eb2bc2.tar.xz
python/python-Safe: Added (Check the password strength).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-Safe/README1
-rw-r--r--python/python-Safe/python-Safe.SlackBuild86
-rw-r--r--python/python-Safe/python-Safe.info10
-rw-r--r--python/python-Safe/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python-Safe/README b/python/python-Safe/README
new file mode 100644
index 0000000000..83b7d2914a
--- /dev/null
+++ b/python/python-Safe/README
@@ -0,0 +1 @@
+Is your password safe? Safe will check the password strength for you.
diff --git a/python/python-Safe/python-Safe.SlackBuild b/python/python-Safe/python-Safe.SlackBuild
new file mode 100644
index 0000000000..7a83bf4d08
--- /dev/null
+++ b/python/python-Safe/python-Safe.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python-Safe
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-Safe
+SRCNAM=$(printf $PRGNAM | cut -c8-11)
+VERSION=${VERSION:-0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-Safe/python-Safe.info b/python/python-Safe/python-Safe.info
new file mode 100644
index 0000000000..6c10302a6b
--- /dev/null
+++ b/python/python-Safe/python-Safe.info
@@ -0,0 +1,10 @@
+PRGNAM="python-Safe"
+VERSION="0.4"
+HOMEPAGE="https://github.com/lepture/safe"
+DOWNLOAD="https://pypi.python.org/packages/d2/3d/ea0fa7a262431f4b94845df59637bbb4ccac9d03a696ca1d894631da8614/Safe-0.4.tar.gz"
+MD5SUM="670ef3588b98f878dd1b38b13d8f677d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-Safe/slack-desc b/python/python-Safe/slack-desc
new file mode 100644
index 0000000000..99fdb05981
--- /dev/null
+++ b/python/python-Safe/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-Safe: python-Safe (Check the password strength)
+python-Safe:
+python-Safe: Is your password safe? Safe will check the password strength for you.
+python-Safe:
+python-Safe: Homepage: https://github.com/lepture/safe
+python-Safe:
+python-Safe:
+python-Safe:
+python-Safe:
+python-Safe:
+python-Safe: