summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-19 19:27:58 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-20 07:49:48 +0700
commitff9fd8b5a70ed192cf572465f9e8a3e2bdf9973a (patch)
tree1d1dc83aaba8f0fb058cb0d1ecbc8ed71c78ec39 /python
parent2b42e20408ddc33e05c96a4424bf6ad3846b1855 (diff)
downloadslackbuilds-ff9fd8b5a70ed192cf572465f9e8a3e2bdf9973a.tar.gz
slackbuilds-ff9fd8b5a70ed192cf572465f9e8a3e2bdf9973a.tar.xz
python/pyqode.cobol: Added (Adds COBOL support to pyqode.core).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyqode.cobol/README1
-rw-r--r--python/pyqode.cobol/pyqode.cobol.SlackBuild85
-rw-r--r--python/pyqode.cobol/pyqode.cobol.info10
-rw-r--r--python/pyqode.cobol/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/pyqode.cobol/README b/python/pyqode.cobol/README
new file mode 100644
index 0000000000..0fc9f496a6
--- /dev/null
+++ b/python/pyqode.cobol/README
@@ -0,0 +1 @@
+pyqode.cobol adds COBOL support to pyQode (code completion, code folding,...).
diff --git a/python/pyqode.cobol/pyqode.cobol.SlackBuild b/python/pyqode.cobol/pyqode.cobol.SlackBuild
new file mode 100644
index 0000000000..39f7b0e10d
--- /dev/null
+++ b/python/pyqode.cobol/pyqode.cobol.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for pyqode.cobol
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyqode.cobol
+VERSION=${VERSION:-2.10.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyqode.cobol/pyqode.cobol.info b/python/pyqode.cobol/pyqode.cobol.info
new file mode 100644
index 0000000000..edb6e404af
--- /dev/null
+++ b/python/pyqode.cobol/pyqode.cobol.info
@@ -0,0 +1,10 @@
+PRGNAM="pyqode.cobol"
+VERSION="2.10.0"
+HOMEPAGE="https://github.com/pyQode/pyqode.cobol"
+DOWNLOAD="https://pypi.python.org/packages/93/06/db4949712cc5bc60e6181eb5254c09ee6a05b4ecaf6a555d0ccd6ba928a3/pyqode.cobol-2.10.0.tar.gz"
+MD5SUM="28d1f97db94009fc5507375d8df0c92b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyqode.core"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pyqode.cobol/slack-desc b/python/pyqode.cobol/slack-desc
new file mode 100644
index 0000000000..cf336fd745
--- /dev/null
+++ b/python/pyqode.cobol/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyqode.cobol: pyqode.cobol (Adds COBOL support to pyqode.core)
+pyqode.cobol:
+pyqode.cobol: pyqode.cobol adds COBOL support to pyQode (code completion,
+pyqode.cobol: code folding,...).
+pyqode.cobol:
+pyqode.cobol: Homepage: https://github.com/pyQode/pyqode.cobol
+pyqode.cobol:
+pyqode.cobol:
+pyqode.cobol:
+pyqode.cobol:
+pyqode.cobol: