summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2016-07-16 23:12:52 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-17 07:48:45 +0700
commite5175bb9950a9a91e9fb8064c320d3a8e79a9c11 (patch)
tree1b861db717d37ec28d7889adbf9e455179611eec /python
parent8fad32b3502b208191fe30c3880dbd95c6fa05f2 (diff)
downloadslackbuilds-e5175bb9950a9a91e9fb8064c320d3a8e79a9c11.tar.gz
slackbuilds-e5175bb9950a9a91e9fb8064c320d3a8e79a9c11.tar.xz
python/psutil: Updated for version 4.3.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/psutil/psutil.SlackBuild19
-rw-r--r--python/psutil/psutil.info6
2 files changed, 16 insertions, 9 deletions
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index 7503837b6e..aafbc3d9b1 100644
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for psutil
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-3.3.0}
+VERSION=${VERSION:-4.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,9 +45,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-release-$VERSION
+tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
+cd $PRGNAM-release-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -55,6 +55,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Remove shebangs
+find psutil -name "*\.py" | while read line; do
+ sed -i.orig '/^#!/d' $line
+ touch -r ${line}.orig $line
+ rm ${line}.orig
+done
+
python setup.py install --root=$PKG
# Install python3 bindings for psutil. Default is no.
@@ -66,7 +73,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CREDITS LICENSE TODO *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CREDITS IDEAS LICENSE *.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/psutil/psutil.info b/python/psutil/psutil.info
index c08fdecf40..d3cc235ccb 100644
--- a/python/psutil/psutil.info
+++ b/python/psutil/psutil.info
@@ -1,8 +1,8 @@
PRGNAM="psutil"
-VERSION="3.3.0"
+VERSION="4.3.0"
HOMEPAGE="https://github.com/giampaolo/psutil"
-DOWNLOAD="https://pypi.python.org/packages/source/p/psutil/psutil-3.3.0.tar.gz"
-MD5SUM="0625db01ea46417308db94cc59362b65"
+DOWNLOAD="https://github.com/giampaolo/psutil/archive/release-4.3.0/psutil-release-4.3.0.tar.gz"
+MD5SUM="da4c7183ff42a6997b8a743305463d10"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""