summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-15 12:52:19 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-17 06:55:49 +0700
commit08a3def83cbc241a627ef95d777b2b52b626627d (patch)
treef231f0c4e49f85ae671d0f0436bb502393ddd8fe /python
parentaad6215f83d568abfe221090e3cead9d4a67e564 (diff)
downloadslackbuilds-08a3def83cbc241a627ef95d777b2b52b626627d.tar.gz
slackbuilds-08a3def83cbc241a627ef95d777b2b52b626627d.tar.xz
python/ptyprocess: Added (python module).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/ptyprocess/README8
-rw-r--r--python/ptyprocess/ptyprocess.SlackBuild92
-rw-r--r--python/ptyprocess/ptyprocess.info10
-rw-r--r--python/ptyprocess/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/python/ptyprocess/README b/python/ptyprocess/README
new file mode 100644
index 0000000000..e80b0e9429
--- /dev/null
+++ b/python/ptyprocess/README
@@ -0,0 +1,8 @@
+ptyprocess (python module)
+
+Launch a subprocess in a pseudo terminal (pty), and interact with
+both the process and its pty.
+Sometimes, piping stdin and stdout is not enough. There might be
+a password prompt that doesn’t read from stdin, output that changes
+when it’s going to a pipe rather than a terminal, or curses-style
+interfaces that rely on a terminal.
diff --git a/python/ptyprocess/ptyprocess.SlackBuild b/python/ptyprocess/ptyprocess.SlackBuild
new file mode 100644
index 0000000000..a896bb6855
--- /dev/null
+++ b/python/ptyprocess/ptyprocess.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for ptyprocess
+
+# Copyright 2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ptyprocess
+VERSION=${VERSION:-0.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION/ -type f -exec chmod 644 {} \;
+chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/ptyprocess/ptyprocess.info b/python/ptyprocess/ptyprocess.info
new file mode 100644
index 0000000000..0bfd1c6250
--- /dev/null
+++ b/python/ptyprocess/ptyprocess.info
@@ -0,0 +1,10 @@
+PRGNAM="ptyprocess"
+VERSION="0.5.1"
+HOMEPAGE="https://pypi.python.org/pypi/ptyprocess"
+DOWNLOAD="https://pypi.python.org/packages/db/d7/b465161910f3d1cef593c5e002bff67e0384898f597f1a7fdc8db4c02bf6/ptyprocess-0.5.1.tar.gz"
+MD5SUM="94e537122914cc9ec9c1eadcd36e73a1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackbuilds.org"
diff --git a/python/ptyprocess/slack-desc b/python/ptyprocess/slack-desc
new file mode 100644
index 0000000000..41fffb9db6
--- /dev/null
+++ b/python/ptyprocess/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ptyprocess: ptyprocess (python module)
+ptyprocess:
+ptyprocess: Launch a subprocess in a pseudo terminal (pty), and interact with
+ptyprocess: both the process and its pty.
+ptyprocess: Sometimes, piping stdin and stdout is not enough. There might be
+ptyprocess: a password prompt that doesn’t read from stdin, output that changes
+ptyprocess: when it’s going to a pipe rather than a terminal, or curses-style
+ptyprocess: interfaces that rely on a terminal.
+ptyprocess:
+ptyprocess: Project URL: https://pypi.python.org/pypi/ptyprocess
+ptyprocess: