summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Michales Michaloudes <korgie@gmail.com>2017-02-08 22:46:30 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-11 07:24:30 +0700
commitf70efdce75daaba20277cdb57c868c6060dc8458 (patch)
treea23515e8a99d26bbf4c80aa8921f5624f5a3114e /python
parentfbc5eebe5fe64efe751e1bf9af6d326229e7279b (diff)
downloadslackbuilds-f70efdce75daaba20277cdb57c868c6060dc8458.tar.gz
slackbuilds-f70efdce75daaba20277cdb57c868c6060dc8458.tar.xz
python/python-ly: Added (python parser for lilyPond files).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-ly/README4
-rw-r--r--python/python-ly/python-ly.SlackBuild69
-rw-r--r--python/python-ly/python-ly.info10
-rw-r--r--python/python-ly/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/python/python-ly/README b/python/python-ly/README
new file mode 100644
index 0000000000..da506d6af8
--- /dev/null
+++ b/python/python-ly/README
@@ -0,0 +1,4 @@
+This package provides a Python library ly containing various Python modules to
+parse, manipulate or create documents in LilyPond format. A command line
+program ly is also provided that can be used to do various manipulations with
+LilyPond files.
diff --git a/python/python-ly/python-ly.SlackBuild b/python/python-ly/python-ly.SlackBuild
new file mode 100644
index 0000000000..db723cd24f
--- /dev/null
+++ b/python/python-ly/python-ly.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+# Slackware build script for <python-ly>
+#
+# Michales (clavisound) Michaloudes korgie@gmail.com <2017>
+
+PRGNAM=python-ly
+VERSION=${VERSION:-0.9.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog README.rst INSTALL.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-ly/python-ly.info b/python/python-ly/python-ly.info
new file mode 100644
index 0000000000..0a37c9ad66
--- /dev/null
+++ b/python/python-ly/python-ly.info
@@ -0,0 +1,10 @@
+PRGNAM="python-ly"
+VERSION="0.9.4"
+HOMEPAGE="https://pypi.python.org/pypi/python-ly/"
+DOWNLOAD="https://pypi.python.org/packages/57/4f/889579244947368f28eda66b782331b1e75f83fd72e63f9ece93cd7a18f9/python-ly-0.9.4.tar.gz"
+MD5SUM="14c8f6bb5c887564af187d1fd5fbbc91"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Michales Michaloudes"
+EMAIL="korgie@gmail.com"
diff --git a/python/python-ly/slack-desc b/python/python-ly/slack-desc
new file mode 100644
index 0000000000..10c6b22d47
--- /dev/null
+++ b/python/python-ly/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-ly: python-ly (python parser for lilyPond files)
+python-ly:
+python-ly: This package provides a Python library ly containing various Python
+python-ly: modules to parse, manipulate or create documents in LilyPond format.
+python-ly: A command line program ly is also provided that can be user to do
+python-ly: various manipulation with LilyPond files.
+python-ly:
+python-ly:
+python-ly:
+python-ly:
+python-ly: