summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-22 17:18:14 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-26 18:29:04 +0700
commit91a05a83e9750b5560de7ad5eef181f1f175d9d1 (patch)
tree53c654bae573aedb67e1c624643de4b1fd0b8981 /python
parent70d56de7eb7d1dd8d10e27acc9665ce62f390744 (diff)
downloadslackbuilds-91a05a83e9750b5560de7ad5eef181f1f175d9d1.tar.gz
slackbuilds-91a05a83e9750b5560de7ad5eef181f1f175d9d1.tar.xz
python/python-lastfm: Removed (Upstream project is gone).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-lastfm/README2
-rw-r--r--python/python-lastfm/nostdeb.diff15
-rw-r--r--python/python-lastfm/python-lastfm.SlackBuild67
-rw-r--r--python/python-lastfm/python-lastfm.info10
-rw-r--r--python/python-lastfm/slack-desc19
5 files changed, 0 insertions, 113 deletions
diff --git a/python/python-lastfm/README b/python/python-lastfm/README
deleted file mode 100644
index f043600b95..0000000000
--- a/python/python-lastfm/README
+++ /dev/null
@@ -1,2 +0,0 @@
-A python interface to the last.fm web services API. Its under development
-now and the code in SVN is incomplete.
diff --git a/python/python-lastfm/nostdeb.diff b/python/python-lastfm/nostdeb.diff
deleted file mode 100644
index 83d1ea07bc..0000000000
--- a/python/python-lastfm/nostdeb.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-*** setup.py 2009-03-04 09:34:14.000000000 +0200
---- setup1.py 2009-03-04 09:36:03.000000000 +0200
-***************
-*** 1,5 ****
- #!/usr/bin/env python
-! import stdeb
- __author__ = "Abhinav Sarkar <abhinav@abhinavsarkar.net>"
- __version__ = "0.1"
- __license__ = "GNU Lesser General Public License"
---- 1,5 ----
- #!/usr/bin/env python
-!
- __author__ = "Abhinav Sarkar <abhinav@abhinavsarkar.net>"
- __version__ = "0.1"
- __license__ = "GNU Lesser General Public License"
diff --git a/python/python-lastfm/python-lastfm.SlackBuild b/python/python-lastfm/python-lastfm.SlackBuild
deleted file mode 100644
index ae18924789..0000000000
--- a/python/python-lastfm/python-lastfm.SlackBuild
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-lastfm
-
-# Written by Mihai Militaru <mihai.militaru@gmx.com>
-# March 2009
-
-PRGNAM=python-lastfm
-ORIGNAM=lastfm
-VERSION=${VERSION:-0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$ORIGNAM-$VERSION.tar.gz
-cd $ORIGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-patch -p0 < $CWD/nostdeb.diff
-
-python setup.py install --root $PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-lastfm/python-lastfm.info b/python/python-lastfm/python-lastfm.info
deleted file mode 100644
index 004016ff5d..0000000000
--- a/python/python-lastfm/python-lastfm.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-lastfm"
-VERSION="0.1"
-HOMEPAGE="http://code.google.com/p/python-lastfm/"
-DOWNLOAD="http://python-lastfm.googlecode.com/svn/trunk/dist/lastfm-0.1.tar.gz"
-MD5SUM="11c85f85fd1bd3a73dbe80473609a151"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mihai Militaru"
-EMAIL="mihai.militaru@gmx.com"
diff --git a/python/python-lastfm/slack-desc b/python/python-lastfm/slack-desc
deleted file mode 100644
index b5426039be..0000000000
--- a/python/python-lastfm/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-lastfm: python-lastfm (python interface to last.fm)
-python-lastfm:
-python-lastfm: A python interface to the last.fm web services API. Its under
-python-lastfm: development now and the code in SVN is incomplete.
-python-lastfm:
-python-lastfm:
-python-lastfm:
-python-lastfm:
-python-lastfm: Homepage: http://code.google.com/p/python-lastfm/
-python-lastfm:
-python-lastfm: