summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2018-05-20 00:18:17 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-05-20 08:35:10 +0700
commit8dfc7eb9451eede76a5bff8b7437486c474d16e1 (patch)
tree7348dc356374545e124f4b9adc266039026bfe22 /python
parent20fc033d84c61efd5238e7a5eb7b092badd0a1f1 (diff)
downloadslackbuilds-8dfc7eb9451eede76a5bff8b7437486c474d16e1.tar.gz
slackbuilds-8dfc7eb9451eede76a5bff8b7437486c474d16e1.tar.xz
python/python3-django: Added (Web framework).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-django/README4
-rw-r--r--python/python3-django/python3-django.SlackBuild89
-rw-r--r--python/python3-django/python3-django.info10
-rw-r--r--python/python3-django/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/python3-django/README b/python/python3-django/README
new file mode 100644
index 0000000000..5d7090a375
--- /dev/null
+++ b/python/python3-django/README
@@ -0,0 +1,4 @@
+Django is a high-level Python Web framework that encourages rapid development
+and clean, pragmatic design. Built by experienced developers, it takes care of
+much of the hassle of Web development, so you can focus on writing your app
+without needing to reinvent the wheel. It’s free and open source.
diff --git a/python/python3-django/python3-django.SlackBuild b/python/python3-django/python3-django.SlackBuild
new file mode 100644
index 0000000000..eda7c82547
--- /dev/null
+++ b/python/python3-django/python3-django.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for python3-django
+
+# Copyright 2018 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-django
+SRCNAM=django
+VERSION=${VERSION:-2.0.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+# Install bash completion file
+mkdir -p $PKG/etc/bash_completion.d
+install -D -m0744 extras/${SRCNAM}_bash_completion \
+ $PKG/etc/bash_completion.d/${SRCNAM}_bash_completion
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CONTRIBUTING.rst INSTALL LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-django/python3-django.info b/python/python3-django/python3-django.info
new file mode 100644
index 0000000000..b21c19c207
--- /dev/null
+++ b/python/python3-django/python3-django.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-django"
+VERSION="2.0.5"
+HOMEPAGE="https://github.com/django/"
+DOWNLOAD="https://github.com/django/django/archive/2.0.5/django-2.0.5.tar.gz"
+MD5SUM="f21147ba61a60184b88e0538f93bcf1b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pytz"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python3-django/slack-desc b/python/python3-django/slack-desc
new file mode 100644
index 0000000000..c5a31cc27a
--- /dev/null
+++ b/python/python3-django/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-django: python3-django (The Web framework for perfectionists with deadlines)
+python3-django:
+python3-django: Django is a high-level Python Web framework that encourages rapid
+python3-django: development and clean, pragmatic design. Built by experienced
+python3-django: developers, it takes care of much of the hassle of Web development,
+python3-django: so you can focus on writing your app without needing to reinvent the
+python3-django: wheel. It’s free and open source.
+python3-django:
+python3-django: Homepage: https://www.djangoproject.com/
+python3-django:
+python3-django: