summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:22 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:50 +0700
commit3589b74c4679ad2d16d58f6790f58c02d377ccdc (patch)
treec3fa5a2183958ed696a528c50fa859136e49a9cc /python
parent6c0dfa094b990f03f19521263a91f0b0250bac9f (diff)
downloadslackbuilds-3589b74c4679ad2d16d58f6790f58c02d377ccdc.tar.gz
slackbuilds-3589b74c4679ad2d16d58f6790f58c02d377ccdc.tar.xz
python/python-pmw: Renamed python2-pmw.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-pmw/slack-desc19
-rw-r--r--python/python2-pmw/README (renamed from python/python-pmw/README)0
-rw-r--r--python/python2-pmw/python2-pmw.SlackBuild (renamed from python/python-pmw/python-pmw.SlackBuild)10
-rw-r--r--python/python2-pmw/python2-pmw.info (renamed from python/python-pmw/python-pmw.info)2
-rw-r--r--python/python2-pmw/slack-desc19
5 files changed, 25 insertions, 25 deletions
diff --git a/python/python-pmw/slack-desc b/python/python-pmw/slack-desc
deleted file mode 100644
index d22737ba26..0000000000
--- a/python/python-pmw/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-pmw: python-pmw (Python Megawidgets, based on top of Tkinter)
-python-pmw:
-python-pmw: It is a toolkit for building high-level compound widgets in
-python-pmw: Python using the Tkinter module. It consists of a set of base
-python-pmw: classes and a library of flexible and extensible megawidgets
-python-pmw: built on this foundation. These megawidgets include notebooks,
-python-pmw: comboboxes, selection widgets, paned widgets, scrolled widgets
-python-pmw: and dialog windows.
-python-pmw:
-python-pmw: Homepage: http://pmw.sourceforge.net/
-python-pmw:
diff --git a/python/python-pmw/README b/python/python2-pmw/README
index 8363f1840d..8363f1840d 100644
--- a/python/python-pmw/README
+++ b/python/python2-pmw/README
diff --git a/python/python-pmw/python-pmw.SlackBuild b/python/python2-pmw/python2-pmw.SlackBuild
index f452ea0a08..61fd5fefac 100644
--- a/python/python-pmw/python-pmw.SlackBuild
+++ b/python/python2-pmw/python2-pmw.SlackBuild
@@ -22,14 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-pmw
+PRGNAM=python2-pmw
VERSION=${VERSION:-1.3.3b}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -44,7 +44,7 @@ SRCPRGNAM=Pmw
SRCSUBDIR=Pmw_1_3_3
SRCVERSION=1_3_3b
-if [ "$ARCH" = "i486" ]; then
+if [ "$ARCH" = "i586" ]; then
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
LIBDIRSUFFIX=""
@@ -65,7 +65,7 @@ mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${SRCPRGNAM}_${SRCVERSION}.tar.gz
cd $SRCPRGNAM/$SRCPRGNAM
-chown -R root:root . || true
+chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
@@ -78,7 +78,7 @@ mv README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cd ..
-python ./setup.py install --root=$PKG
+python2 ./setup.py install --root=$PKG
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/python-pmw/python-pmw.info b/python/python2-pmw/python2-pmw.info
index fd83184773..2395206c36 100644
--- a/python/python-pmw/python-pmw.info
+++ b/python/python2-pmw/python2-pmw.info
@@ -1,4 +1,4 @@
-PRGNAM="python-pmw"
+PRGNAM="python2-pmw"
VERSION="1.3.3b"
HOMEPAGE="http://pmw.sourceforge.net"
DOWNLOAD="http://downloads.sourceforge.net/pmw/Pmw_1_3_3b.tar.gz"
diff --git a/python/python2-pmw/slack-desc b/python/python2-pmw/slack-desc
new file mode 100644
index 0000000000..7a18ecf483
--- /dev/null
+++ b/python/python2-pmw/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pmw: python2-pmw (Python Megawidgets, based on top of Tkinter)
+python2-pmw:
+python2-pmw: It is a toolkit for building high-level compound widgets in
+python2-pmw: Python using the Tkinter module. It consists of a set of base
+python2-pmw: classes and a library of flexible and extensible megawidgets
+python2-pmw: built on this foundation. These megawidgets include notebooks,
+python2-pmw: comboboxes, selection widgets, paned widgets, scrolled widgets
+python2-pmw: and dialog windows.
+python2-pmw:
+python2-pmw: Homepage: http://pmw.sourceforge.net/
+python2-pmw: