summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:26 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:51 +0700
commitd50f427d4ecc9bf6b57e162bc85bdaf16df3652a (patch)
treedde2d2ec680d8df8922f45f8dce809b5f3239291 /python
parent393b89f89f8cc63bb66cc4f236256d01495ecd9f (diff)
downloadslackbuilds-d50f427d4ecc9bf6b57e162bc85bdaf16df3652a.tar.gz
slackbuilds-d50f427d4ecc9bf6b57e162bc85bdaf16df3652a.tar.xz
python/python-transaction: Renamed python2-transaction.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-transaction/slack-desc19
-rw-r--r--python/python2-transaction/README (renamed from python/python-transaction/README)8
-rw-r--r--python/python2-transaction/python2-transaction.SlackBuild (renamed from python/python-transaction/python-transaction.SlackBuild)12
-rw-r--r--python/python2-transaction/python2-transaction.info (renamed from python/python-transaction/python-transaction.info)2
-rw-r--r--python/python2-transaction/slack-desc19
5 files changed, 30 insertions, 30 deletions
diff --git a/python/python-transaction/slack-desc b/python/python-transaction/slack-desc
deleted file mode 100644
index 2d0a163b2d..0000000000
--- a/python/python-transaction/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-transaction: python-transaction (Python Transaction Management)
-python-transaction:
-python-transaction: This is a generic transaction implementation for Python. It
-python-transaction: is mainly used by the ZODB. Note that the data manager API,
-python-transaction: transaction.interfaces.IDataManager, is syntactically simple, but
-python-transaction: semantically complex. The semantics were not easy to express in the
-python-transaction: interface. The semantics are presented in detail through examples
-python-transaction: of a sample data manager in transaction.tests.test_SampleDataManager.
-python-transaction:
-python-transaction:
-python-transaction: Homepage: https://pypi.python.org/pypi/transaction
diff --git a/python/python-transaction/README b/python/python2-transaction/README
index f80fdb9017..8c1d022bd7 100644
--- a/python/python-transaction/README
+++ b/python/python2-transaction/README
@@ -1,8 +1,8 @@
-This package contains a generic transaction implementation for Python. It
-is mainly used by the ZODB, though.
+This package contains a generic transaction implementation for Python.
+It is mainly used by the ZODB, though.
Note that the data manager API, transaction.interfaces.IDataManager, is
syntactically simple, but semantically complex. The semantics were not
easy to express in the interface. This could probably use more work. The
-semantics are presented in detail through examples of a sample data manager
-in transaction.tests.test_SampleDataManager.
+semantics are presented in detail through examples of a sample data
+manager in transaction.tests.test_SampleDataManager.
diff --git a/python/python-transaction/python-transaction.SlackBuild b/python/python2-transaction/python2-transaction.SlackBuild
index d47c3353b6..b14885edc3 100644
--- a/python/python-transaction/python-transaction.SlackBuild
+++ b/python/python2-transaction/python2-transaction.SlackBuild
@@ -6,7 +6,7 @@
# Written by Lionel Young <redtricycle@gmail.com>
-PRGNAM=python-transaction
+PRGNAM=python2-transaction
SRCNAM=transaction
VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
@@ -14,7 +14,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -25,8 +25,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -54,8 +54,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python2 setup.py build || exit 1
+python2 setup.py install --root=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-transaction/python-transaction.info b/python/python2-transaction/python2-transaction.info
index 177c94dcce..072626bc1b 100644
--- a/python/python-transaction/python-transaction.info
+++ b/python/python2-transaction/python2-transaction.info
@@ -1,4 +1,4 @@
-PRGNAM="python-transaction"
+PRGNAM="python2-transaction"
VERSION="1.0.0"
HOMEPAGE="https://pypi.python.org/pypi/transaction"
DOWNLOAD="https://pypi.python.org/packages/source/t/transaction/transaction-1.0.0.tar.gz"
diff --git a/python/python2-transaction/slack-desc b/python/python2-transaction/slack-desc
new file mode 100644
index 0000000000..f3b0c1c060
--- /dev/null
+++ b/python/python2-transaction/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-transaction: python2-transaction (Python Transaction Management)
+python2-transaction:
+python2-transaction: This is a generic transaction implementation for Python. It
+python2-transaction: is mainly used by the ZODB. Note that the data manager API,
+python2-transaction: transaction.interfaces.IDataManager, is syntactically simple, but
+python2-transaction: semantically complex. The semantics were not easy to express in the
+python2-transaction: interface. The semantics are presented in detail through examples
+python2-transaction: of a sample data manager in transaction.tests.test_SampleDataManager.
+python2-transaction:
+python2-transaction:
+python2-transaction: Homepage: https://pypi.python.org/pypi/transaction