summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2022-09-23 22:39:56 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-09-25 13:59:41 +0700
commitdb083da9c924becbe9ddb6d5489a077fc4f721b1 (patch)
treecb6ecd55276d1c71b9d88c5137ef6b0ff91e6210 /python
parent24584bda44bc5db333d103eede45c10a10bda57f (diff)
downloadslackbuilds-db083da9c924becbe9ddb6d5489a077fc4f721b1.tar.gz
slackbuilds-db083da9c924becbe9ddb6d5489a077fc4f721b1.tar.xz
python/pluggy: Remove python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pluggy/README2
-rw-r--r--python/pluggy/pluggy.SlackBuild5
-rw-r--r--python/pluggy/pluggy.info4
3 files changed, 6 insertions, 5 deletions
diff --git a/python/pluggy/README b/python/pluggy/README
index e05d99fe75..588eb17442 100644
--- a/python/pluggy/README
+++ b/python/pluggy/README
@@ -2,3 +2,5 @@ pluggy (mechanisms for python)
This is the plugin manager as used by pytest but stripped of pytest
specific details.
+
+This is the Python 2 build of pluggy.
diff --git a/python/pluggy/pluggy.SlackBuild b/python/pluggy/pluggy.SlackBuild
index 3f209cd47a..bc1c5f3328 100644
--- a/python/pluggy/pluggy.SlackBuild
+++ b/python/pluggy/pluggy.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pluggy
VERSION=${VERSION:-0.13.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,13 +81,12 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst PKG-INFO LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pluggy/pluggy.info b/python/pluggy/pluggy.info
index d500a6d3f8..afda47b4e2 100644
--- a/python/pluggy/pluggy.info
+++ b/python/pluggy/pluggy.info
@@ -1,10 +1,10 @@
PRGNAM="pluggy"
VERSION="0.13.1"
HOMEPAGE="https://github.com/pytest-dev/pluggy"
-DOWNLOAD="https://files.pythonhosted.org/packages/f8/04/7a8542bed4b16a65c2714bf76cf5a0b026157da7f75e87cc88774aa10b14/pluggy-0.13.1.tar.gz"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pluggy/pluggy-0.13.1.tar.gz"
MD5SUM="7f610e28b8b34487336b585a3dfb803d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python2-setuptools-scm"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.coM"
+EMAIL="isaacyu1@isaacyu1.com"