summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2021-05-04 22:33:36 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 00:48:27 +0700
commitf2a87cc3eaa9b63e46f3a1ec3e598c4cf60ee7b6 (patch)
tree267ca99419b2b9eaf3707d0dc850709aba577e29 /python
parent408425cde1dd4ae296f2fc3535dc3eb64284befa (diff)
downloadslackbuilds-f2a87cc3eaa9b63e46f3a1ec3e598c4cf60ee7b6.tar.gz
slackbuilds-f2a87cc3eaa9b63e46f3a1ec3e598c4cf60ee7b6.tar.xz
python/itsdangerous: Updated for version 1.1.0.
There's a very real chance that I'm breaking something with this commit, so feel free to revert if I did. This is the last version that supported python2, so it seemed like the most safe upgrade... Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/itsdangerous/itsdangerous.SlackBuild7
-rw-r--r--python/itsdangerous/itsdangerous.info6
2 files changed, 7 insertions, 6 deletions
diff --git a/python/itsdangerous/itsdangerous.SlackBuild b/python/itsdangerous/itsdangerous.SlackBuild
index f1f5bbad14..e13ef8f2d4 100644
--- a/python/itsdangerous/itsdangerous.SlackBuild
+++ b/python/itsdangerous/itsdangerous.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=itsdangerous
-VERSION=${VERSION:-0.24}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,13 +69,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README CHANGES LICENSE PKG-INFO docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst CHANGES.rst LICENSE.rst PKG-INFO docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/itsdangerous/itsdangerous.info b/python/itsdangerous/itsdangerous.info
index 227540b539..d17a64918c 100644
--- a/python/itsdangerous/itsdangerous.info
+++ b/python/itsdangerous/itsdangerous.info
@@ -1,8 +1,8 @@
PRGNAM="itsdangerous"
-VERSION="0.24"
+VERSION="1.1.0"
HOMEPAGE="https://github.com/mitsuhiko/itsdangerous"
-DOWNLOAD="https://pypi.python.org/packages/source/i/itsdangerous/itsdangerous-0.24.tar.gz"
-MD5SUM="a3d55aa79369aef5345c036a8a26307f"
+DOWNLOAD="https://pypi.python.org/packages/source/i/itsdangerous/itsdangerous-1.1.0.tar.gz"
+MD5SUM="9b7f5afa7f1e3acfb7786eeca3d99307"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""