summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+github@gmail.com>2024-05-06 23:54:23 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-11 06:51:49 +0700
commit008cacc6027890284c11be4dfd62039645c2c779 (patch)
tree34a7bc6477a1f1ceae25dc2f806047ec2073e6d1 /python
parenta28e25a29ab078d6fc4d63ce592db2c3a8c72dc1 (diff)
downloadslackbuilds-008cacc6027890284c11be4dfd62039645c2c779.tar.gz
slackbuilds-008cacc6027890284c11be4dfd62039645c2c779.tar.xz
python/python3-dogpile.cache: Version bump to 1.3.3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild15
-rw-r--r--python/python3-dogpile.cache/python3-dogpile.cache.info6
2 files changed, 17 insertions, 4 deletions
diff --git a/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild b/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
index 2902d6c931..92b122b07b 100644
--- a/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
+++ b/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-dogpile.cache
-VERSION=${VERSION:-1.3.2}
+VERSION=${VERSION:-1.3.3}
SRCNAM=${SRCNAM:-dogpile.cache}
SRCVER=${SRCVER:-rel_$(echo $VERSION | tr . _)}
BUILD=${BUILD:-1}
@@ -66,6 +66,19 @@ find -L . \
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages/
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir "$PKG" dist/*.whl
diff --git a/python/python3-dogpile.cache/python3-dogpile.cache.info b/python/python3-dogpile.cache/python3-dogpile.cache.info
index 0a1e30fad5..be9404d531 100644
--- a/python/python3-dogpile.cache/python3-dogpile.cache.info
+++ b/python/python3-dogpile.cache/python3-dogpile.cache.info
@@ -1,8 +1,8 @@
PRGNAM="python3-dogpile.cache"
-VERSION="1.3.2"
+VERSION="1.3.3"
HOMEPAGE="https://dogpilecache.sqlalchemy.org/"
-DOWNLOAD="https://github.com/sqlalchemy/dogpile.cache/archive/rel_1_3_2/dogpile.cache-rel_1_3_2.tar.gz"
-MD5SUM="b8b7172ee282d5ccf2238cb141d6f3a5"
+DOWNLOAD="https://github.com/sqlalchemy/dogpile.cache/archive/rel_1_3_3/dogpile.cache-rel_1_3_3.tar.gz"
+MD5SUM="3a252847b9d7c7c083786dd9ddf95afa"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-stevedore python3-decorator typing-extensions python3-setuptools-opt"