summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2024-05-10 00:39:02 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-11 08:12:25 +0700
commitcfe294f9ca3ac472e1967bfe7b884c3c32a3a67f (patch)
treeb87185b36bf4b45f90a70c9a86207907bdf25f76 /python
parent6e6c704a418f8651fcffe57f6d9ccbc872eec00d (diff)
downloadslackbuilds-cfe294f9ca3ac472e1967bfe7b884c3c32a3a67f.tar.gz
slackbuilds-cfe294f9ca3ac472e1967bfe7b884c3c32a3a67f.tar.xz
python/python3-cheroot: Updated for version 10.0.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-cheroot/python3-cheroot.SlackBuild27
-rw-r--r--python/python3-cheroot/python3-cheroot.info8
2 files changed, 11 insertions, 24 deletions
diff --git a/python/python3-cheroot/python3-cheroot.SlackBuild b/python/python3-cheroot/python3-cheroot.SlackBuild
index 37bbafe3f2..42572eef31 100644
--- a/python/python3-cheroot/python3-cheroot.SlackBuild
+++ b/python/python3-cheroot/python3-cheroot.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-cheroot
-# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-cheroot
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-10.0.0}
+VERSION=${VERSION:-10.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -50,23 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,7 +65,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-cheroot/python3-cheroot.info b/python/python3-cheroot/python3-cheroot.info
index 0d031ba05c..d8108ff27a 100644
--- a/python/python3-cheroot/python3-cheroot.info
+++ b/python/python3-cheroot/python3-cheroot.info
@@ -1,10 +1,10 @@
PRGNAM="python3-cheroot"
-VERSION="10.0.0"
+VERSION="10.0.1"
HOMEPAGE="https://cheroot.cherrypy.dev"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cheroot/cheroot-10.0.0.tar.gz"
-MD5SUM="be96fa052c54892240f916fbb06cc571"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cheroot/cheroot-10.0.1.tar.gz"
+MD5SUM="0fce2608fcb31c16c81945c73e283724"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-jaraco.functools python3-setuptools_scm_git_archive"
+REQUIRES="python3-setuptools-scm-opt python3-jaraco.functools"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"