summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2021-01-02 10:39:00 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-01-09 14:30:44 +0700
commit9acb80f101b0f0056935f79e1d9843c383aae91e (patch)
treeb150bdb5caeb78e108bf7bb15f95538c3507456b /python
parent1c4a37e164bacf617f42acf2659331796236b26d (diff)
downloadslackbuilds-9acb80f101b0f0056935f79e1d9843c383aae91e.tar.gz
slackbuilds-9acb80f101b0f0056935f79e1d9843c383aae91e.tar.xz
python/python3-certifi: Removed as python-certifi now supports Python 3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-certifi/README2
-rw-r--r--python/python3-certifi/python3-certifi.SlackBuild90
-rw-r--r--python/python3-certifi/python3-certifi.info10
-rw-r--r--python/python3-certifi/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/python/python3-certifi/README b/python/python3-certifi/README
deleted file mode 100644
index c7257f4714..0000000000
--- a/python/python3-certifi/README
+++ /dev/null
@@ -1,2 +0,0 @@
-This installable Python package contains a CA Bundle that you can reference in
-your Python code.
diff --git a/python/python3-certifi/python3-certifi.SlackBuild b/python/python3-certifi/python3-certifi.SlackBuild
deleted file mode 100644
index 15d16d51cc..0000000000
--- a/python/python3-certifi/python3-certifi.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-certifi
-
-# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Based on python-certifi by Dimitris Zlatanidis
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python3-certifi
-VERSION=${VERSION:-2019.6.16}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=certifi
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-certifi/python3-certifi.info b/python/python3-certifi/python3-certifi.info
deleted file mode 100644
index 8b1d1ea2dc..0000000000
--- a/python/python3-certifi/python3-certifi.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-certifi"
-VERSION="2019.6.16"
-HOMEPAGE="https://pypi.python.org/pypi/certifi/"
-DOWNLOAD="https://pypi.python.org/packages/source/c/certifi/certifi-2019.6.16.tar.gz"
-MD5SUM="af8fea5f3df6f7f81e9c6cbc6dd7c1e8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-certifi/slack-desc b/python/python3-certifi/slack-desc
deleted file mode 100644
index cc79fa4126..0000000000
--- a/python/python3-certifi/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-certifi: python3-certifi (Python SSL Certificates)
-python3-certifi:
-python3-certifi: This installable Python package contains a python3-certifi: CA
-python3-certifi: Bundle that you can reference in your Python code.
-python3-certifi:
-python3-certifi:
-python3-certifi:
-python3-certifi:
-python3-certifi:
-python3-certifi:
-python3-certifi: