summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-01-22 12:17:36 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-28 08:22:49 +0700
commit0778d5f37688d724b61b6100974216e95540a6dc (patch)
tree62fe406fda411b8a09c7b41ac3cd3036d6a13102 /python
parentd6a4df0f3131154235f02b287a496782ace50b21 (diff)
downloadslackbuilds-0778d5f37688d724b61b6100974216e95540a6dc.tar.gz
slackbuilds-0778d5f37688d724b61b6100974216e95540a6dc.tar.xz
python/python3-Flask-RESTX: Updated for version 1.0.5.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild11
-rw-r--r--python/python3-Flask-RESTX/python3-Flask-RESTX.info6
2 files changed, 7 insertions, 10 deletions
diff --git a/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild b/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
index 7c30543df4..eeed241292 100644
--- a/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
+++ b/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-RESTX
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-RESTX
SRCNAM=$(echo ${PRGNAM,,} | sed "s/python3-//")
-VERSION=${VERSION:-1.0.3}
+VERSION=${VERSION:-1.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-Flask-RESTX/python3-Flask-RESTX.info b/python/python3-Flask-RESTX/python3-Flask-RESTX.info
index 632b466ff8..ae57366f8a 100644
--- a/python/python3-Flask-RESTX/python3-Flask-RESTX.info
+++ b/python/python3-Flask-RESTX/python3-Flask-RESTX.info
@@ -1,8 +1,8 @@
PRGNAM="python3-Flask-RESTX"
-VERSION="1.0.3"
+VERSION="1.0.5"
HOMEPAGE="https://github.com/python-restx/flask-restx"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-restx/flask-restx-1.0.3.tar.gz"
-MD5SUM="1d0d080f9e59ddec21cfed5273abcbc7"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-restx/flask-restx-1.0.5.tar.gz"
+MD5SUM="875d745f1550e7985684135cbcca856c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-aniso8601 Flask python3-jsonschema pytz"