summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2020-05-16 08:22:12 +0200
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:55:23 -0500
commit0a204058a01637d2fd342e137952c8c8cd2edfda (patch)
treedce623da2e320bd40cb952f278cd416657bc2168 /python
parent4b57af6b8c6ec6cb9c14a2fb3988bdb9b787d3b2 (diff)
downloadslackbuilds-0a204058a01637d2fd342e137952c8c8cd2edfda.tar.gz
slackbuilds-0a204058a01637d2fd342e137952c8c8cd2edfda.tar.xz
python/python3-Cython: Removed (added to Slackware).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-Cython/README5
-rw-r--r--python/python3-Cython/python3-Cython.SlackBuild89
-rw-r--r--python/python3-Cython/python3-Cython.info10
-rw-r--r--python/python3-Cython/slack-desc19
4 files changed, 0 insertions, 123 deletions
diff --git a/python/python3-Cython/README b/python/python3-Cython/README
deleted file mode 100644
index 0dd3a3eda4..0000000000
--- a/python/python3-Cython/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Cython is an optimising static compiler for both the Python programming
-language and the extended Cython programming language (based on Pyrex).
-It makes writing C extensions for Python as easy as Python itself.
-
-This SlackBuild may be installed alongside the stock Cython package.
diff --git a/python/python3-Cython/python3-Cython.SlackBuild b/python/python3-Cython/python3-Cython.SlackBuild
deleted file mode 100644
index 173569230e..0000000000
--- a/python/python3-Cython/python3-Cython.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-Cython
-
-# Copyright 2016-2020 Christoph Willing Brisbane, Australia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python3-Cython
-SRCNAM=Cython
-VERSION=${VERSION:-0.29.17}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG --prefix=/usr
-
-# Rename executables to avoid clashes with stock Cython versions
-find $PKG/usr/bin/ -type f -executable -exec mv '{}' '{}'3 \;
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-Cython/python3-Cython.info b/python/python3-Cython/python3-Cython.info
deleted file mode 100644
index 9fb6e094c1..0000000000
--- a/python/python3-Cython/python3-Cython.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-Cython"
-VERSION="0.29.17"
-HOMEPAGE="https://cython.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/99/36/a3dc962cc6d08749aa4b9d85af08b6e354d09c5468a3e0edc610f44c856b/Cython-0.29.17.tar.gz"
-MD5SUM="0936311ccd09f1164ab2f46ca5cd8c3b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Christoph Willing"
-EMAIL="chris.willing@linux.com"
diff --git a/python/python3-Cython/slack-desc b/python/python3-Cython/slack-desc
deleted file mode 100644
index 9c2bdbf818..0000000000
--- a/python/python3-Cython/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-Cython: python3-Cython (C-Extensions for Python3)
-python3-Cython:
-python3-Cython: Cython is an optimising static compiler for both the Python
-python3-Cython: programming language and the extended Cython programming language
-python3-Cython: (based on Pyrex). It makes writing C extensions for Python as easy
-python3-Cython: as Python itself.
-python3-Cython:
-python3-Cython: This SlackBuild may be installed alongside the stock Cython package.
-python3-Cython:
-python3-Cython:
-python3-Cython: