summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-03-13 09:34:37 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-03-15 00:26:22 +0700
commit0aede26dd2d867cff115d66d2859da360c0ed503 (patch)
tree9d4a2c629fdae7a148067b49dfda1ace5ffd14a6 /python
parent58eabffc280ed3200cd0e4e339de15ec11cdc36d (diff)
downloadslackbuilds-0aede26dd2d867cff115d66d2859da360c0ed503.tar.gz
slackbuilds-0aede26dd2d867cff115d66d2859da360c0ed503.tar.xz
python/docopt: Added Python3 support and update README.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/docopt/README2
-rw-r--r--python/docopt/docopt.SlackBuild9
2 files changed, 9 insertions, 2 deletions
diff --git a/python/docopt/README b/python/docopt/README
index de9ee4f9c6..349148631b 100644
--- a/python/docopt/README
+++ b/python/docopt/README
@@ -1,3 +1,5 @@
docopt helps you
* define interface for your command-line app
* automatically generate parser for it.
+
+Python3 is an optional dependency.
diff --git a/python/docopt/docopt.SlackBuild b/python/docopt/docopt.SlackBuild
index 8cd9f6c289..0ae1b0b601 100644
--- a/python/docopt/docopt.SlackBuild
+++ b/python/docopt/docopt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for docopt
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=docopt
VERSION=${VERSION:-0.6.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true