summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2018-11-18 15:52:11 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-24 12:35:19 +0700
commit2005e827de03a9a6381c25712086972b0061b03f (patch)
treee67800ff1721f9b67bca5dd03a6d708c1f22d871 /python
parentb8562092d77a4adcd558b766e105d65a8a97e527 (diff)
downloadslackbuilds-2005e827de03a9a6381c25712086972b0061b03f.tar.gz
slackbuilds-2005e827de03a9a6381c25712086972b0061b03f.tar.xz
python/lxml: Add python3 bindings by default
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python')
-rw-r--r--python/lxml/README6
-rw-r--r--python/lxml/lxml.SlackBuild6
2 files changed, 3 insertions, 9 deletions
diff --git a/python/lxml/README b/python/lxml/README
index 99f8dc670b..a038bd0592 100644
--- a/python/lxml/README
+++ b/python/lxml/README
@@ -2,10 +2,6 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
It is unique in that it combines the speed and feature completeness
of these libraries with the simplicity of a native Python API.
-Optional dependencies: python3, BeautifulSoup and cssselect
+Optional dependencies: BeautifulSoup and cssselect
BeautifulSoup can be used in place of BeautifulSoup4.
-
-Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
-
- # PYTHON3=yes ./lxml.SlackBuild
diff --git a/python/lxml/lxml.SlackBuild b/python/lxml/lxml.SlackBuild
index df1ee9fe02..ed6222ed25 100644
--- a/python/lxml/lxml.SlackBuild
+++ b/python/lxml/lxml.SlackBuild
@@ -68,10 +68,8 @@ find -L . \
python2 setup.py build --with-unicode-strings
python2 setup.py install --skip-build --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py build --with-unicode-strings
- python3 setup.py install --skip-build --root=$PKG
-fi
+python3 setup.py build --with-unicode-strings
+python3 setup.py install --skip-build --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true