summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Markus Rinne <markus.ka.rinne@gmail.com>2018-08-16 22:03:15 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-08-18 08:39:48 +0700
commit25cab77e9e5138a9ac6752ddaf65afdaf9d2253a (patch)
treea26b04184ac9fbeccef13bd98a43a8fa50cf4740 /python
parent619da28b3d203b3ea4641f4a11655c0c4fa3ac81 (diff)
downloadslackbuilds-25cab77e9e5138a9ac6752ddaf65afdaf9d2253a.tar.gz
slackbuilds-25cab77e9e5138a9ac6752ddaf65afdaf9d2253a.tar.xz
python/typed_ast: Added (abstract syntax tree parser).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/typed_ast/README6
-rw-r--r--python/typed_ast/slack-desc19
-rw-r--r--python/typed_ast/typed_ast.SlackBuild87
-rw-r--r--python/typed_ast/typed_ast.info10
4 files changed, 122 insertions, 0 deletions
diff --git a/python/typed_ast/README b/python/typed_ast/README
new file mode 100644
index 0000000000..7f7cea3745
--- /dev/null
+++ b/python/typed_ast/README
@@ -0,0 +1,6 @@
+typed_ast is a Python 3 package that provides a Python 2.7 and Python 3 parser
+similar to the standard ast library. Unlike ast, the parsers in typed_ast
+include PEP 484 type comments and are independent of the version of Python
+under which they are run. The typed_ast parsers produce the standard Python
+AST (plus type comments), and are both fast and correct, as they are based on
+the CPython 2.7 and 3.6 parsers.
diff --git a/python/typed_ast/slack-desc b/python/typed_ast/slack-desc
new file mode 100644
index 0000000000..52730c2664
--- /dev/null
+++ b/python/typed_ast/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+typed_ast: typed_ast (abstract syntax tree parser)
+typed_ast:
+typed_ast: typed_ast is a Python 3 package that provides a Python 2.7 and
+typed_ast: Python 3 parser similar to the standard ast library. Unlike ast, the
+typed_ast: parsers in typed_ast include PEP 484 type comments and are independent
+typed_ast: of the version of Python under which they are run. The typed_ast
+typed_ast: parsers produce the standard Python AST (plus type comments), and are
+typed_ast: both fast and correct, as they are based on the CPython 2.7 and 3.6
+typed_ast: parsers.
+typed_ast:
+typed_ast:
diff --git a/python/typed_ast/typed_ast.SlackBuild b/python/typed_ast/typed_ast.SlackBuild
new file mode 100644
index 0000000000..a058b0e51d
--- /dev/null
+++ b/python/typed_ast/typed_ast.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for typed_ast
+
+# Copyright 2018 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=typed_ast
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CONTRIBUTING.md LICENSE README.md update_process.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/typed_ast/typed_ast.info b/python/typed_ast/typed_ast.info
new file mode 100644
index 0000000000..856e2daf78
--- /dev/null
+++ b/python/typed_ast/typed_ast.info
@@ -0,0 +1,10 @@
+PRGNAM="typed_ast"
+VERSION="1.1.0"
+HOMEPAGE="https://github.com/python/typed_ast"
+DOWNLOAD="https://github.com/python/typed_ast/archive/1.1.0/typed_ast-1.1.0.tar.gz"
+MD5SUM="0895bf89b86f0a38b1335b0917cb174f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"