summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Fernando Lopez Jr <fernando.lopezjr@gmail.com>2018-01-10 10:55:27 +0000
committer David Spencer <idlemoor@slackbuilds.org>2018-01-10 10:55:27 +0000
commit417d4dc8975a79a732914be73debf1eb28d4aff8 (patch)
treebc9b0daeb8769857df1104fb3786934471fc2ac2 /python
parent07354934f6b4754df0c7c1fef9045f719cf89f66 (diff)
downloadslackbuilds-417d4dc8975a79a732914be73debf1eb28d4aff8.tar.gz
slackbuilds-417d4dc8975a79a732914be73debf1eb28d4aff8.tar.xz
python/migen: Updated for version 0.6.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/migen/README16
-rw-r--r--python/migen/migen.SlackBuild5
-rw-r--r--python/migen/migen.info6
-rw-r--r--python/migen/setup.py.patch11
4 files changed, 26 insertions, 12 deletions
diff --git a/python/migen/README b/python/migen/README
index 9672daf61b..2746d93a94 100644
--- a/python/migen/README
+++ b/python/migen/README
@@ -2,12 +2,12 @@ Migen (Milkymist generator)
A Python toolbox for building complex digital hardware.
-The Migen FHDL library replaces the event-driven paradigm with the
-notions of combinatorial and synchronous statements, has arithmetic
-rules that make integers always behave like mathematical integers, and
-most importantly allows the design's logic to be constructed by a
-Python program. This last point enables hardware designers to take
-advantage of the richness of the Python language - object oriented
-programming, function parameters, generators, operator overloading,
-libraries, etc. - to build well organized, reusable and elegant
+The Migen FHDL library replaces the event-driven paradigm with the
+notions of combinatorial and synchronous statements, has arithmetic
+rules that make integers always behave like mathematical integers, and
+most importantly allows the design's logic to be constructed by a
+Python program. This last point enables hardware designers to take
+advantage of the richness of the Python language - object oriented
+programming, function parameters, generators, operator overloading,
+libraries, etc. - to build well organized, reusable and elegant
designs.
diff --git a/python/migen/migen.SlackBuild b/python/migen/migen.SlackBuild
index 4005863660..c7ae2ed42d 100644
--- a/python/migen/migen.SlackBuild
+++ b/python/migen/migen.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=migen
-VERSION=${VERSION:-0.6.dev}
+VERSION=${VERSION:-0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# setup version fix:
+patch -p0 --verbose < $CWD/setup.py.patch
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/migen/migen.info b/python/migen/migen.info
index df27f69d5d..c27fd412c1 100644
--- a/python/migen/migen.info
+++ b/python/migen/migen.info
@@ -1,8 +1,8 @@
PRGNAM="migen"
-VERSION="0.6.dev"
+VERSION="0.6"
HOMEPAGE="https://m-labs.hk/gateware.html"
-DOWNLOAD="https://github.com/m-labs/migen/archive/0.6.dev/migen-0.6.dev.tar.gz"
-MD5SUM="28fd7527f8e5eb4117f0a5b1b708a3d9"
+DOWNLOAD="https://github.com/m-labs/migen/archive/0.6/migen-0.6.tar.gz"
+MD5SUM="88c16dd40e01823b988a14fd216d7bf6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3"
diff --git a/python/migen/setup.py.patch b/python/migen/setup.py.patch
new file mode 100644
index 0000000000..ab3ddd090b
--- /dev/null
+++ b/python/migen/setup.py.patch
@@ -0,0 +1,11 @@
+--- setup.py 2018-01-05 12:28:27.000000000 -0700
++++ setup.py.new 2018-01-09 01:15:45.797982200 -0700
+@@ -15,7 +15,7 @@
+
+ setup(
+ name="migen",
+- version="0.5.dev",
++ version="0.6",
+ description="Python toolbox for building complex digital hardware",
+ long_description=open("README.md").read(),
+ author="Sebastien Bourdeauducq",