summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundyat>2022-05-20 18:07:21 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:27 +0700
commit6673438a40958ace02e7fe8cb166106a37ff35d3 (patch)
tree0eb7e3e5cbd30e697d8859ae23e4d935a86a8294 /python
parentd933d5a0cf39d2076e1f3d17f93b98888d0a4978 (diff)
downloadslackbuilds-6673438a40958ace02e7fe8cb166106a37ff35d3.tar.gz
slackbuilds-6673438a40958ace02e7fe8cb166106a37ff35d3.tar.xz
python/plaso: Updated for version 20220428.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/plaso/plaso.SlackBuild8
-rw-r--r--python/plaso/plaso.info8
2 files changed, 8 insertions, 8 deletions
diff --git a/python/plaso/plaso.SlackBuild b/python/plaso/plaso.SlackBuild
index 99af90bab2..1946ee1849 100644
--- a/python/plaso/plaso.SlackBuild
+++ b/python/plaso/plaso.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for plaso
-# Copyright 2015-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2015-2022 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated Build version 20190131, March 2019
+# Updated Build version 20220428, May 2022
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=plaso
-VERSION=${VERSION:-20190131}
+VERSION=${VERSION:-20220428}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/plaso/plaso.info b/python/plaso/plaso.info
index b8d80d9bcc..9d33b44bc2 100644
--- a/python/plaso/plaso.info
+++ b/python/plaso/plaso.info
@@ -1,10 +1,10 @@
PRGNAM="plaso"
-VERSION="20190131"
+VERSION="20220428"
HOMEPAGE="https://github.com/log2timeline/plaso"
-DOWNLOAD="https://github.com/log2timeline/plaso/releases/download/20190131/plaso-20190131.tar.gz"
-MD5SUM="42402d1a43b7145d34f91bb3d64ef346"
+DOWNLOAD="https://linuxleo.com/Source/plaso-20220428.tar.gz"
+MD5SUM="8591b1e290e5cd31800a83a0d4ded76c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="dfvfs artifacts bencode biplist python2-dateutil dfwinreg dotty elasticsearch5 hachoir-metadata python2-lz4 pefile psutil python2-pyzmq pytz XlsxWriter libesedb libevt libevtx libfwsi liblnk libmsiecf libolecf libscca yara-python"
+REQUIRES="dfvfs artifacts python3-bencode python3-dateutil python3-defusedxml dfwinreg python3-lz4 pefile psutil python3-pyzmq pytz libesedb libevt libevtx libfwsi liblnk libmsiecf libolecf libscca redis-py python3-yara XlsxWriter"
MAINTAINER="Barry J. Grundy"
EMAIL="bgrundy<at>linuxleo.com"