summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:48 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:53 +0700
commit73ea7ad7aa9bfa159532e6d993e5c84638394454 (patch)
tree1c784f94bf87204c2f58d48c800abb647e1a4185 /python
parent289662417467d15824a2959e7d517df764c81f71 (diff)
downloadslackbuilds-73ea7ad7aa9bfa159532e6d993e5c84638394454.tar.gz
slackbuilds-73ea7ad7aa9bfa159532e6d993e5c84638394454.tar.xz
python/python-yenc: Renamed python2-yenc.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-yenc/README7
-rw-r--r--python/python-yenc/slack-desc19
-rw-r--r--python/python2-yenc/README9
-rw-r--r--python/python2-yenc/python2-yenc.SlackBuild (renamed from python/python-yenc/python-yenc.SlackBuild)10
-rw-r--r--python/python2-yenc/python2-yenc.info (renamed from python/python-yenc/python-yenc.info)2
-rw-r--r--python/python2-yenc/slack-desc19
6 files changed, 34 insertions, 32 deletions
diff --git a/python/python-yenc/README b/python/python-yenc/README
deleted file mode 100644
index 716a3a3ab8..0000000000
--- a/python/python-yenc/README
+++ /dev/null
@@ -1,7 +0,0 @@
- yEnc - a raw encoding/decoding module for Python
-
-This a fairly simple module, it provide only raw yEnc encoding/decoding with
-builitin crc32 calculation.
-Header parsing, checkings and yenc formatting are left to you (see examples
-directory for possible implementations). The interface was originally intended
-to be similar to the uu module from Python standard library.
diff --git a/python/python-yenc/slack-desc b/python/python-yenc/slack-desc
deleted file mode 100644
index ff198d7585..0000000000
--- a/python/python-yenc/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-yenc: python-yenc (raw encoding/decoding module for python)
-python-yenc:
-python-yenc: This a fairly simple module, it provide only raw yEnc
-python-yenc: encoding/decoding with builtin crc32 calculation.
-python-yenc:
-python-yenc: Header parsing, checkings and yenc formatting are left to you
-python-yenc: (see examples directory for possible implementations).
-python-yenc: The interface originally intended to be similar to the uu
-python-yenc: module from Python standard library.
-python-yenc:
-python-yenc:
diff --git a/python/python2-yenc/README b/python/python2-yenc/README
new file mode 100644
index 0000000000..59ddd5e880
--- /dev/null
+++ b/python/python2-yenc/README
@@ -0,0 +1,9 @@
+yEnc - a raw encoding/decoding module for Python
+
+This a fairly simple module, it provide only raw yEnc encoding/decoding
+with builitin crc32 calculation.
+
+Header parsing, checkings and yenc formatting are left to you (see
+examples directory for possible implementations). The interface was
+originally intended to be similar to the uu module from Python standard
+library.
diff --git a/python/python-yenc/python-yenc.SlackBuild b/python/python2-yenc/python2-yenc.SlackBuild
index 52e4fbc8c9..5bce68003b 100644
--- a/python/python-yenc/python-yenc.SlackBuild
+++ b/python/python2-yenc/python2-yenc.SlackBuild
@@ -4,7 +4,7 @@
# Written by powtrix (@gmail.com)
-PRGNAM=python-yenc
+PRGNAM=python2-yenc
VERSION=${VERSION:-0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -13,7 +13,7 @@ SRCNAM=yenc
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -24,8 +24,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -53,7 +53,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
rm -f $PKG/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages/yenc-0.3-py2.6.egg-info
diff --git a/python/python-yenc/python-yenc.info b/python/python2-yenc/python2-yenc.info
index 68f23bd3de..d1907377c5 100644
--- a/python/python-yenc/python-yenc.info
+++ b/python/python2-yenc/python2-yenc.info
@@ -1,4 +1,4 @@
-PRGNAM="python-yenc"
+PRGNAM="python2-yenc"
VERSION="0.3"
HOMEPAGE="https://sabnzbd.org/"
DOWNLOAD="http://ponce.cc/slackware/sources/repo/yenc-0.3.tar.gz"
diff --git a/python/python2-yenc/slack-desc b/python/python2-yenc/slack-desc
new file mode 100644
index 0000000000..486c84b348
--- /dev/null
+++ b/python/python2-yenc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-yenc: python2-yenc (raw encoding/decoding module for python)
+python2-yenc:
+python2-yenc: This a fairly simple module, it provide only raw yEnc
+python2-yenc: encoding/decoding with builtin crc32 calculation.
+python2-yenc:
+python2-yenc: Header parsing, checkings and yenc formatting are left to you
+python2-yenc: (see examples directory for possible implementations).
+python2-yenc: The interface originally intended to be similar to the uu
+python2-yenc: module from Python standard library.
+python2-yenc:
+python2-yenc: