summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2015-12-05 01:25:45 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-12-05 01:25:45 +0700
commit751dc143ba202efc8ec93607aeec937a76af6a5b (patch)
treebfecb74a2a22372360fd1e05bda726ff805de60d /python
parentdd0e44c0e6a1e0c507549316bfd7f44a5fcbaa8e (diff)
downloadslackbuilds-751dc143ba202efc8ec93607aeec937a76af6a5b.tar.gz
slackbuilds-751dc143ba202efc8ec93607aeec937a76af6a5b.tar.xz
python/python-pillow: Added (Python Imaging Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-pillow/README4
-rw-r--r--python/python-pillow/python-pillow.SlackBuild91
-rw-r--r--python/python-pillow/python-pillow.info10
-rw-r--r--python/python-pillow/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python-pillow/README b/python/python-pillow/README
new file mode 100644
index 0000000000..7ca0b3e5cd
--- /dev/null
+++ b/python/python-pillow/README
@@ -0,0 +1,4 @@
+The Python Imaging Library (PIL) adds image processing capabilities to
+your Python environment. This library provides extensive file format
+support, an efficient internal representation, and powerful image
+processing capabilities.
diff --git a/python/python-pillow/python-pillow.SlackBuild b/python/python-pillow/python-pillow.SlackBuild
new file mode 100644
index 0000000000..e9676a6e50
--- /dev/null
+++ b/python/python-pillow/python-pillow.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for python-pillow
+
+# Copyright 2009, 2010, 2013, 2014 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2014 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Maintainer notes:
+# Copied from -current python-pillow (Thu Oct 29 20:12:14 UTC 2015)
+#
+
+PRGNAM=python-pillow
+VERSION=${VERSION:-3.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf Pillow-$VERSION
+tar xvf $CWD/Pillow-$VERSION.tar.gz
+cd Pillow-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE *.md *.rst docs/BUILDME docs/COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-pillow/python-pillow.info b/python/python-pillow/python-pillow.info
new file mode 100644
index 0000000000..d107ed6ce2
--- /dev/null
+++ b/python/python-pillow/python-pillow.info
@@ -0,0 +1,10 @@
+PRGNAM="python-pillow"
+VERSION="3.0.0"
+HOMEPAGE="http://python-pillow.github.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/P/Pillow/Pillow-3.0.0.tar.gz"
+MD5SUM="fc8ac44e93da09678eac7e30c9b7377d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools libwebp"
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"
diff --git a/python/python-pillow/slack-desc b/python/python-pillow/slack-desc
new file mode 100644
index 0000000000..313987b191
--- /dev/null
+++ b/python/python-pillow/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-pillow: python-pillow (Python Imaging Library)
+python-pillow:
+python-pillow: The Python Imaging Library (PIL) adds image processing capabilities
+python-pillow: to your Python environment. This library provides extensive file
+python-pillow: format support, an efficient internal representation, and powerful
+python-pillow: image processing capabilities.
+python-pillow:
+python-pillow: PIL homepage: https://python-pillow.github.io/
+python-pillow:
+python-pillow:
+python-pillow: