summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-04-15 09:33:32 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-16 12:12:52 +0700
commit835f15310e27025a1a91dfefe0d04f5a67bfa5f9 (patch)
tree6de27f4868bb20ba4e601125aab2ab727a55173d /python
parent4de42dc354dfff76065aa0aad42ea01baabc465d (diff)
downloadslackbuilds-835f15310e27025a1a91dfefe0d04f5a67bfa5f9.tar.gz
slackbuilds-835f15310e27025a1a91dfefe0d04f5a67bfa5f9.tar.xz
python/dulwich: removed, unused and replaced by python3 version
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/dulwich/README4
-rw-r--r--python/dulwich/dulwich.SlackBuild81
-rw-r--r--python/dulwich/dulwich.info10
-rw-r--r--python/dulwich/slack-desc19
4 files changed, 0 insertions, 114 deletions
diff --git a/python/dulwich/README b/python/dulwich/README
deleted file mode 100644
index 7ec8b93eeb..0000000000
--- a/python/dulwich/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Dulwich is a Python implementation of the Git file formats and
-protocols. It aims to give an interface to git repos (both local and
-remote) that doesn't call out to git directly but instead uses pure
-Python.
diff --git a/python/dulwich/dulwich.SlackBuild b/python/dulwich/dulwich.SlackBuild
deleted file mode 100644
index 5381c7fc82..0000000000
--- a/python/dulwich/dulwich.SlackBuild
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for dulwich
-
-# Copyright 2012-2017 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=dulwich
-VERSION=${VERSION:-0.18.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/dulwich/dulwich.info b/python/dulwich/dulwich.info
deleted file mode 100644
index d0d9bb11ea..0000000000
--- a/python/dulwich/dulwich.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="dulwich"
-VERSION="0.18.6"
-HOMEPAGE="https://www.dulwich.io/"
-DOWNLOAD="https://pypi.python.org/packages/3e/e9/96f83f49a02d9e5ba8e906aa6c19f1394de96f7c662bc8fe4520ceff0f7a/dulwich-0.18.6.tar.gz"
-MD5SUM="9d71e5ab10d889eb3fdff13f49f301bc"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/python/dulwich/slack-desc b/python/dulwich/slack-desc
deleted file mode 100644
index 70f4ba517d..0000000000
--- a/python/dulwich/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-dulwich: dulwich (Python implementation of Git formats and protocols)
-dulwich:
-dulwich: Dulwich is a Python implementation of the Git file formats and
-dulwich: protocols. It aims to give an interface to git repos (both local and
-dulwich: remote) that doesn't call out to git directly but instead uses pure
-dulwich: Python. The project is named after the village in which Mr. and
-dulwich: Mrs. Git live in the Monty Python sketch.
-dulwich:
-dulwich: Homepage: https://www.dulwich.io/
-dulwich:
-dulwich: