summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Pr. HORSTMANN <wmh@eipg.fr>2020-12-26 12:15:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-12-26 12:15:02 +0700
commit927b9c952624b94f36b92ca9153dc583ded1f7e5 (patch)
treeed9ab1ebb66a2f1c6a5e2af6bf47bfc051fb346a /python
parent7d1985f4cdbd89c4c75f9bb63fbede01ee53a086 (diff)
downloadslackbuilds-927b9c952624b94f36b92ca9153dc583ded1f7e5.tar.gz
slackbuilds-927b9c952624b94f36b92ca9153dc583ded1f7e5.tar.xz
python/scikit-umfpack: Added (wrapper of UMFPACK).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/scikit-umfpack/README1
-rw-r--r--python/scikit-umfpack/scikit-umfpack.SlackBuild106
-rw-r--r--python/scikit-umfpack/scikit-umfpack.info10
-rw-r--r--python/scikit-umfpack/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/python/scikit-umfpack/README b/python/scikit-umfpack/README
new file mode 100644
index 0000000000..5c9c049722
--- /dev/null
+++ b/python/scikit-umfpack/README
@@ -0,0 +1 @@
+scikit-umfpack provides wrapper of UMFPACK sparse direct solver to SciPy.
diff --git a/python/scikit-umfpack/scikit-umfpack.SlackBuild b/python/scikit-umfpack/scikit-umfpack.SlackBuild
new file mode 100644
index 0000000000..99de5a1762
--- /dev/null
+++ b/python/scikit-umfpack/scikit-umfpack.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/sh
+
+# SlackBuild build script for scikit-umfpack
+
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=scikit-umfpack
+VERSION=${VERSION:-0.3.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+#set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+ ( if [ -f /usr/include/umfpack/umfpack.h ]; then
+ echo "umfpack detected."
+ echo
+ echo "The umfpack.h needs to be patched before building to ensure that"
+ echo "the scikit-umfpack has amd module and its amd.h include is found."
+ echo
+ cd /usr/include/umfpack
+ find . -type f -name "umfpack.h" -print0 | xargs -0 sed -i 's/#include "amd.h"/#include <amd\/amd.h>/g'
+fi )
+
+# Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/scikit-umfpack/scikit-umfpack.info b/python/scikit-umfpack/scikit-umfpack.info
new file mode 100644
index 0000000000..ca34bd0c13
--- /dev/null
+++ b/python/scikit-umfpack/scikit-umfpack.info
@@ -0,0 +1,10 @@
+PRGNAM="scikit-umfpack"
+VERSION="0.3.2"
+HOMEPAGE="https://pypi.org/project/scikit-umfpack/"
+DOWNLOAD="https://files.pythonhosted.org/packages/38/70/12391037c558543518a8c2446b583dfd9fc2e0237cbdcd67ddef3ae98e97/scikit-umfpack-0.3.2.tar.gz"
+MD5SUM="a92e3b8b7c864a9d5b25bf3d1a7ca39c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="numpy scipy umfpack"
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/scikit-umfpack/slack-desc b/python/scikit-umfpack/slack-desc
new file mode 100644
index 0000000000..33d6c854ba
--- /dev/null
+++ b/python/scikit-umfpack/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+scikit-umfpack: scikit-umfpack (wrapper of UMFPACK sparse direct solver to SciPy)
+scikit-umfpack:
+scikit-umfpack: scikit-umfpack provides wrapper of UMFPACK sparse direct solver to
+scikit-umfpack: SciPy.
+scikit-umfpack:
+scikit-umfpack:
+scikit-umfpack: Homepage: https://pypi.org/project/scikit-umfpack/
+scikit-umfpack:
+scikit-umfpack:
+scikit-umfpack:
+scikit-umfpack: