summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-01-07 13:33:44 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-07 11:14:02 -0600
commit96c2163657c6dac7351392c779520af1dd17bb33 (patch)
treeaf7cfe171c53c8b80f384750b3bd9a25f9935496 /python
parent1668891aa1912726b3cb028d2d868f0dde3bc3d0 (diff)
downloadslackbuilds-96c2163657c6dac7351392c779520af1dd17bb33.tar.gz
slackbuilds-96c2163657c6dac7351392c779520af1dd17bb33.tar.xz
python/colorama: Added (Cross-platform colored terminal text).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/colorama/README29
-rw-r--r--python/colorama/colorama.SlackBuild96
-rw-r--r--python/colorama/colorama.info10
-rw-r--r--python/colorama/slack-desc19
4 files changed, 154 insertions, 0 deletions
diff --git a/python/colorama/README b/python/colorama/README
new file mode 100644
index 0000000000..3b8b8fc503
--- /dev/null
+++ b/python/colorama/README
@@ -0,0 +1,29 @@
+Makes ANSI escape character sequences for producing colored terminal
+text and cursor positioning work under MS Windows.
+ANSI escape character sequences have long been used to produce colored
+terminal text and cursor positioning on Unix and Macs. Colorama makes this
+work on Windows, too, by wrapping stdout, stripping ANSI sequences it finds
+(which otherwise show up as gobbledygook in your output), and converting
+them into the appropriate win32 calls to modify the state of the terminal.
+On other platforms, Colorama does nothing.
+
+Colorama also provides some shortcuts to help generate ANSI sequences but
+works fine in conjunction with any other ANSI sequence generation library,
+such as Termcolor (http://pypi.python.org/pypi/termcolor.)
+
+This has the upshot of providing a simple cross-platform API for printing
+colored terminal text from Python, and has the happy side-effect that
+existing applications or libraries which use ANSI sequences to produce
+colored output on Linux or Macs can now also work on Windows, simply by
+calling colorama.init().
+
+An alternative approach is to install 'ansi.sys' on Windows machines,
+which provides the same behaviour for all applications running in
+terminals. Colorama is intended for situations where that isn't easy
+(e.g. maybe your app doesn't have an installer.)
+
+Demo scripts in the source code repository prints some colored text
+using ANSI sequences. Compare their output under Gnome-terminal's
+built in ANSI handling, versus on Windows Command-Prompt using
+Colorama.
+See demos files '$ /usr/doc/colorama-0.2.7/'
diff --git a/python/colorama/colorama.SlackBuild b/python/colorama/colorama.SlackBuild
new file mode 100644
index 0000000000..5a52a119cf
--- /dev/null
+++ b/python/colorama/colorama.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for colorama
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=colorama
+VERSION=${VERSION:-0.2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
+cp '-a' \
+ README.txt PKG-INFO CHANGELOG.rst LICENSE.txt \
+ demos/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/colorama/colorama.info b/python/colorama/colorama.info
new file mode 100644
index 0000000000..08da4f2c01
--- /dev/null
+++ b/python/colorama/colorama.info
@@ -0,0 +1,10 @@
+PRGNAM="colorama"
+VERSION="0.2.7"
+HOMEPAGE="http://code.google.com/p/colorama/"
+DOWNLOAD="https://pypi.python.org/packages/source/c/colorama/colorama-0.2.7.tar.gz"
+MD5SUM="2c30fa1472c7dfa7ff5cf931fd9e4988"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/colorama/slack-desc b/python/colorama/slack-desc
new file mode 100644
index 0000000000..bc7954f3b0
--- /dev/null
+++ b/python/colorama/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+colorama: colorama (Cross-platform colored terminal text)
+colorama:
+colorama: Makes ANSI escape character sequences for producing colored terminal
+colorama: text and cursor positioning work under MS Windows.
+colorama: ANSI escape character sequences have long been used to produce colored
+colorama: terminal text and cursor positioning on Unix and Macs.
+colorama:
+colorama:
+colorama:
+colorama: Homepage : http://code.google.com/p/colorama/
+colorama: