summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2013-11-07 11:28:08 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-11-07 11:28:19 -0600
commitb78013477a6ddb5854741327e49a654a8711911d (patch)
tree576d68aaea1a4a2176219d2f25cfbe74af2fd774 /python
parent81f45fa8236ef553189bee08a74f820faa898245 (diff)
downloadslackbuilds-b78013477a6ddb5854741327e49a654a8711911d.tar.gz
slackbuilds-b78013477a6ddb5854741327e49a654a8711911d.tar.xz
python/babel: Updated for version 1.3, added a license.
Changed homepage, cleanups Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/babel/README3
-rw-r--r--python/babel/babel.SlackBuild42
-rw-r--r--python/babel/babel.info8
3 files changed, 36 insertions, 17 deletions
diff --git a/python/babel/README b/python/babel/README
index eba89f2670..89f867c5c2 100644
--- a/python/babel/README
+++ b/python/babel/README
@@ -6,3 +6,6 @@ It's composed of two major parts:
- a Python interface to the CLDR (Common Locale Data Repository),
providing access to various locale display names, localized number
and date formatting, etc.
+
+Refer to the official homepage for documentation
+http://babel.pocoo.org/docs/
diff --git a/python/babel/babel.SlackBuild b/python/babel/babel.SlackBuild
index 004e142974..89698f1109 100644
--- a/python/babel/babel.SlackBuild
+++ b/python/babel/babel.SlackBuild
@@ -1,12 +1,29 @@
#!/bin/sh
# Slackware build script for babel
-
-# Written by Matteo Bernardini <ponce@slackbuilds.org>
+#
+# Copyright 2013 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=babel
-SRCNAM=Babel
-VERSION=${VERSION:-0.9.6}
+VERSION=${VERSION:-1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -42,24 +59,23 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
-cp -a COPYING ChangeLog README.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION/html
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/babel/babel.info b/python/babel/babel.info
index bdee39e142..4c03289ce6 100644
--- a/python/babel/babel.info
+++ b/python/babel/babel.info
@@ -1,8 +1,8 @@
PRGNAM="babel"
-VERSION="0.9.6"
-HOMEPAGE="http://babel.edgewall.org/"
-DOWNLOAD="http://ftp.edgewall.com/pub/babel/Babel-0.9.6.tar.gz"
-MD5SUM="f0edcad03dfdb5505f337ef1a7690325"
+VERSION="1.3"
+HOMEPAGE="http://babel.pocoo.org/"
+DOWNLOAD="https://github.com/mitsuhiko/babel/archive/1.3.tar.gz"
+MD5SUM="752ecd661a4002d64ba07384404a2988"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""