summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2019-01-05 10:49:46 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:55:26 -0500
commitbbdf957b9c521e084456f3e2689d60af40dc76f4 (patch)
treea77dda83be07b052a6f2194c666e81b3f97fa1f6 /python
parent4f956e2af9b0b373c1dfe6e39956be04123ad7f2 (diff)
downloadslackbuilds-bbdf957b9c521e084456f3e2689d60af40dc76f4.tar.gz
slackbuilds-bbdf957b9c521e084456f3e2689d60af40dc76f4.tar.xz
libraries/python3-pyparsing: Removed (added to Slackware).
...as part of pyparsing Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pyparsing/README8
-rw-r--r--python/python3-pyparsing/python3-pyparsing.SlackBuild88
-rw-r--r--python/python3-pyparsing/python3-pyparsing.info10
-rw-r--r--python/python3-pyparsing/slack-desc19
4 files changed, 0 insertions, 125 deletions
diff --git a/python/python3-pyparsing/README b/python/python3-pyparsing/README
deleted file mode 100644
index d2badb1992..0000000000
--- a/python/python3-pyparsing/README
+++ /dev/null
@@ -1,8 +0,0 @@
-The pyparsing module is an alternative approach to creating and
-executing simple grammars, vs. the traditional lex/yacc
-approach, or the use of regular expressions. The pyparsing
-module provides a library of classes that client code uses to
-construct the grammar directly in Python code.
-
-This is the python3 version of pyparsing and it can coexist with
-SBo's pyparsing package.
diff --git a/python/python3-pyparsing/python3-pyparsing.SlackBuild b/python/python3-pyparsing/python3-pyparsing.SlackBuild
deleted file mode 100644
index b98c10cd31..0000000000
--- a/python/python3-pyparsing/python3-pyparsing.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-pyparsing
-
-# Copyright 2008-2012 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2016 Barry Grundy (bgrundy<at>linuxleo.com)
-# Copyright 2017-2018 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python3-pyparsing
-SRCNAM=pyparsing
-VERSION=${VERSION:-2.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE PKG-INFO README HowToUsePyparsing.html docs/ $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-pyparsing/python3-pyparsing.info b/python/python3-pyparsing/python3-pyparsing.info
deleted file mode 100644
index ab429a468b..0000000000
--- a/python/python3-pyparsing/python3-pyparsing.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-pyparsing"
-VERSION="2.2.0"
-HOMEPAGE="https://github.com/pyparsing/pyparsing"
-DOWNLOAD="http://downloads.sourceforge.net/project/pyparsing/pyparsing/pyparsing-2.2.0/pyparsing-2.2.0.tar.gz"
-MD5SUM="0214e42d63af850256962b6744c948d9"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Jeremy Hansen"
-EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-pyparsing/slack-desc b/python/python3-pyparsing/slack-desc
deleted file mode 100644
index 32aebd1da2..0000000000
--- a/python/python3-pyparsing/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-pyparsing: python3-pyparsing (parsing module for python)
-python3-pyparsing:
-python3-pyparsing: The pyparsing module is an alternative approach to creating and
-python3-pyparsing: executing simple grammars, vs. the traditional lex/yacc
-python3-pyparsing: approach, or the use of regular expressions. The pyparsing
-python3-pyparsing: module provides a library of classes that client code uses to
-python3-pyparsing: construct the grammar directly in Python code.
-python3-pyparsing:
-python3-pyparsing: Homepage: http://pyparsing.wikispaces.com/
-python3-pyparsing:
-python3-pyparsing: This is the python3 version and will coexist with the python2 version.