summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2018-11-20 10:48:31 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-24 12:35:12 +0700
commitbf057b8b98a2cd86222ddf52e3b4451334c41f69 (patch)
tree51f53d5ddcc179f402d89b8b485ad29ceda8025a /python
parentd9ec97b3b480fcc885da92fb86535b9698709d3b (diff)
downloadslackbuilds-bf057b8b98a2cd86222ddf52e3b4451334c41f69.tar.gz
slackbuilds-bf057b8b98a2cd86222ddf52e3b4451334c41f69.tar.xz
python/xarray: Added (N-D labeled arrays and datasets).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/xarray/README9
-rw-r--r--python/xarray/slack-desc19
-rw-r--r--python/xarray/xarray.SlackBuild87
-rw-r--r--python/xarray/xarray.info10
4 files changed, 125 insertions, 0 deletions
diff --git a/python/xarray/README b/python/xarray/README
new file mode 100644
index 0000000000..9b2f842138
--- /dev/null
+++ b/python/xarray/README
@@ -0,0 +1,9 @@
+xarray is an open source project and Python package that aims to bring the
+labeled data power of pandas to the physical sciences, by providing
+N-dimensional variants of the core pandas data structures.
+
+The goal is to provide a pandas-like and pandas-compatible toolkit for
+analytics on multi-dimensional arrays, rather than the tabular data for which
+pandas excels. Our approach adopts the Common Data Model for self- describing
+scientific data in widespread use in the Earth sciences: xarray.Dataset is an
+in-memory representation of a netCDF file.
diff --git a/python/xarray/slack-desc b/python/xarray/slack-desc
new file mode 100644
index 0000000000..91b420dd17
--- /dev/null
+++ b/python/xarray/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xarray: xarray (N-D labeled arrays and datasets)
+xarray:
+xarray: xarray is an open source project and Python package that aims to
+xarray: bring the labeled data power of pandas to the physical sciences,
+xarray: by providing N-dimensional variants of the core pandas data
+xarray: structures.
+xarray:
+xarray:
+xarray:
+xarray:
+xarray:
diff --git a/python/xarray/xarray.SlackBuild b/python/xarray/xarray.SlackBuild
new file mode 100644
index 0000000000..975ac7a5a2
--- /dev/null
+++ b/python/xarray/xarray.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for xarray
+
+# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=xarray
+VERSION=${VERSION:-0.11.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/xarray/xarray.info b/python/xarray/xarray.info
new file mode 100644
index 0000000000..578b0b51ae
--- /dev/null
+++ b/python/xarray/xarray.info
@@ -0,0 +1,10 @@
+PRGNAM="xarray"
+VERSION="0.11.0"
+HOMEPAGE="http://xarray.pydata.org"
+DOWNLOAD="https://github.com/pydata/xarray/archive/v0.11.0/xarray-0.11.0.tar.gz"
+MD5SUM="f4f71bfa742b9610155ff86c39dc62a2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pandas"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"