summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2012-09-30 20:11:40 -0500
committer Robby Workman <rworkman@slackbuilds.org>2012-09-30 20:11:40 -0500
commitc50b3841d8f4483dadbffa3d6400dbe7648b0b27 (patch)
tree403c31efcf3aaf0f884e9afefd097ac83ceb8181 /python
parent26d01ccdf27615e90edb564622d27436cd45f7ab (diff)
downloadslackbuilds-c50b3841d8f4483dadbffa3d6400dbe7648b0b27.tar.gz
slackbuilds-c50b3841d8f4483dadbffa3d6400dbe7648b0b27.tar.xz
python/pyffmpeg: Removed (build failure)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyffmpeg/README4
-rw-r--r--python/pyffmpeg/pyffmpeg.SlackBuild72
-rw-r--r--python/pyffmpeg/pyffmpeg.info10
-rw-r--r--python/pyffmpeg/slack-desc19
4 files changed, 0 insertions, 105 deletions
diff --git a/python/pyffmpeg/README b/python/pyffmpeg/README
deleted file mode 100644
index 0dbaab9c7e..0000000000
--- a/python/pyffmpeg/README
+++ /dev/null
@@ -1,4 +0,0 @@
-PyFFmpeg is a wrapper around FFmpeg's libavcodec, libavformat and
-libavutil libraries whose main purpose is to provide access to
-individual frames of video files of various formats (including MPEG
-and DIVX encoded videos), and, also in latest beta,to audio data.
diff --git a/python/pyffmpeg/pyffmpeg.SlackBuild b/python/pyffmpeg/pyffmpeg.SlackBuild
deleted file mode 100644
index 934c08feac..0000000000
--- a/python/pyffmpeg/pyffmpeg.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
-# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
-
-# Slackware build script for pyffmpeg
-# Written by Lionel Young <redtricycle@gmail.com>
-# Based on http://slackbuilds.org/template.SlackBuild
-
-
-PRGNAM=pyffmpeg
-VERSION=${VERSION:-2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
- arm*) export ARCH=arm ;;
- *) export ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py build
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING $PKG/usr/doc/$PRGNAM-$VERSION
-cp -aR examples $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyffmpeg/pyffmpeg.info b/python/pyffmpeg/pyffmpeg.info
deleted file mode 100644
index cbee3e3b5b..0000000000
--- a/python/pyffmpeg/pyffmpeg.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyffmpeg"
-VERSION="2.0"
-HOMEPAGE="http://code.google.com/p/pyffmpeg/"
-DOWNLOAD="http://pyffmpeg.googlecode.com/files/pyffmpeg-2.0.tar.gz"
-MD5SUM="fee69342f9c7909bc0586c3e3cd4a6c2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Cython ffmpeg numpy"
-MAINTAINER="Lionel Young"
-EMAIL="redtricycle@gmail.com"
diff --git a/python/pyffmpeg/slack-desc b/python/pyffmpeg/slack-desc
deleted file mode 100644
index 172682956c..0000000000
--- a/python/pyffmpeg/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pyffmpeg: pyffmpeg (FFmpeg wrapper)
-pyffmpeg:
-pyffmpeg: PyFFmpeg is a wrapper around FFmpeg's libavcodec, libavformat
-pyffmpeg: and libavutil libraries whose main purpose is to provide access to
-pyffmpeg: individual frames of video files of various formats (including MPEG
-pyffmpeg: and DIVX encoded videos), and, also in latest beta,to audio data.
-pyffmpeg: Requires: Cython, Numpy, and ffmpeg
-pyffmpeg:
-pyffmpeg: Homepage: http://code.google.com/p/pyffmpeg/
-pyffmpeg:
-pyffmpeg: