summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2013-02-10 18:32:01 -0600
committer Erik Hanson <erik@slackbuilds.org>2013-02-14 00:26:36 -0600
commitd0b861f727abc7e89a62e526b385072ba4802181 (patch)
tree4a481f5291a395f91348299ed0578075a20213a2 /python
parent6500e637b7589319a825e9c924991894a4199214 (diff)
downloadslackbuilds-d0b861f727abc7e89a62e526b385072ba4802181.tar.gz
slackbuilds-d0b861f727abc7e89a62e526b385072ba4802181.tar.xz
python/python3: More path fixes; use system expat and libffi
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3/patches/python3.x86_64.diff12
-rw-r--r--python/python3/python3.SlackBuild9
2 files changed, 19 insertions, 2 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index d97019c544..31ea63fdab 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -100,6 +100,18 @@ diff -uar Python-3.3.0.orig/Lib/sysconfig.py Python-3.3.0/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
+diff -uar Python-3.3.0.orig/Lib/venv/__init__.py Python-3.3.0/Lib/venv/__init__.py
+--- Python-3.3.0.orig/Lib/venv/__init__.py 2012-09-29 11:00:40.000000000 +0300
++++ Python-3.3.0/Lib/venv/__init__.py 2013-02-10 13:29:16.859718301 +0200
+@@ -127,7 +127,7 @@
+ else:
+ binname = 'bin'
+ incpath = 'include'
+- libpath = os.path.join(env_dir, 'lib', 'python%d.%d' % sys.version_info[:2], 'site-packages')
++ libpath = os.path.join(env_dir, 'lib64', 'python%d.%d' % sys.version_info[:2], 'site-packages')
+ context.inc_path = path = os.path.join(env_dir, incpath)
+ create_if_needed(path)
+ create_if_needed(libpath)
diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
--- Python-3.3.0.orig/Makefile.pre.in 2012-09-29 11:00:41.000000000 +0300
+++ Python-3.3.0/Makefile.pre.in 2012-10-09 21:26:05.949858929 +0300
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index 05f2520e62..da7bbe8c4d 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3
-# Copyright 2012 Audrius Kažukauskas <audrius@neutrino.lt>
+# Copyright 2012-2013 Audrius Kažukauskas <audrius@neutrino.lt>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python3
VERSION=${VERSION:-3.3.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -75,6 +75,9 @@ if [ "$ARCH" = "x86_64" ]; then
patch -p1 < $CWD/patches/python3.x86_64.diff
fi
+# Fix python3 path in cgi.py.
+sed -i '1s|^#.*/usr/local/bin/python|#!/usr/bin/python3|' Lib/cgi.py
+
chown -R root:root .
chmod -R u+w,go+r-w,a-s+X .
@@ -86,6 +89,8 @@ chmod -R u+w,go+r-w,a-s+X .
--with-threads \
--enable-ipv6 \
--enable-shared \
+ --with-system-expat \
+ --with-system-ffi \
--build=$ARCH-slackware-linux
make