summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2013-11-06 14:14:08 -0600
committer Robby Workman <rworkman@slackbuilds.org>2013-11-06 14:14:08 -0600
commitd0eeb6d17d392a6f57cd772419bf54b843b0b516 (patch)
tree6a571ef1e1012d38e2837d90cfa5f92fe2d5e720 /python
parent2c91a9250eaf21ca5140ad71cf658f0a467e2db5 (diff)
downloadslackbuilds-d0eeb6d17d392a6f57cd772419bf54b843b0b516.tar.gz
slackbuilds-d0eeb6d17d392a6f57cd772419bf54b843b0b516.tar.xz
python/numexpr: Updated for version 2.2.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/numexpr/numexpr.SlackBuild10
-rw-r--r--python/numexpr/numexpr.info6
2 files changed, 8 insertions, 8 deletions
diff --git a/python/numexpr/numexpr.SlackBuild b/python/numexpr/numexpr.SlackBuild
index ba9058475e..8e489589b9 100644
--- a/python/numexpr/numexpr.SlackBuild
+++ b/python/numexpr/numexpr.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for numexpr
-# Copyright 2010-2013 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2010-2013 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=numexpr
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-2.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,11 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --root=$PKG
diff --git a/python/numexpr/numexpr.info b/python/numexpr/numexpr.info
index 302269a402..8b910799a6 100644
--- a/python/numexpr/numexpr.info
+++ b/python/numexpr/numexpr.info
@@ -1,8 +1,8 @@
PRGNAM="numexpr"
-VERSION="2.2.1"
+VERSION="2.2.2"
HOMEPAGE="http://code.google.com/p/numexpr/"
-DOWNLOAD="http://numexpr.googlecode.com/files/numexpr-2.2.1.tar.gz"
-MD5SUM="d79081537d5a8059c352d57ac27e0305"
+DOWNLOAD="http://numexpr.googlecode.com/files/numexpr-2.2.2.tar.gz"
+MD5SUM="18103954044b3039c0a74a6006c8e0a7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="numpy"