summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-07-20 09:06:40 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-07-20 09:06:40 +0700
commitdb073a77f566ed29868dc2f585c98e45e0ec3ea6 (patch)
tree9f7d8786dd4133518739376a5afb5c06cbcd9b23 /python
parent88bbdc160da0c717cf023f096c74cde658f598e2 (diff)
downloadslackbuilds-db073a77f566ed29868dc2f585c98e45e0ec3ea6.tar.gz
slackbuilds-db073a77f566ed29868dc2f585c98e45e0ec3ea6.tar.xz
python/python-xlib: Update the patch.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-xlib/setup.patch61
-rw-r--r--python/python-xlib/setup.patch.gzbin841 -> 0 bytes
2 files changed, 61 insertions, 0 deletions
diff --git a/python/python-xlib/setup.patch b/python/python-xlib/setup.patch
new file mode 100644
index 0000000000..47be163a34
--- /dev/null
+++ b/python/python-xlib/setup.patch
@@ -0,0 +1,61 @@
+diff --git a/setup.py b/setup.py
+index 71bdb08..b425618 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,17 +1,25 @@
+ # Distutils script for python-xlib
+
+-from pkg_resources import parse_requirements
+-from setuptools import (__version__ as setuptools_version, setup)
++from setuptools import setup
+
+-
+-# Check setuptools is recent enough to support `setup.cfg`.
+-setuptools_require = next(parse_requirements('setuptools>=30.3.0'))
+-assert setuptools_version in setuptools_require, '{} is required'.format(setuptools_require)
++import Xlib
+
+
+ setup(
++ name='python-xlib',
++ version=Xlib.__version_string__,
++
++ description='Python X Library',
++ download_url='https://github.com/python-xlib/python-xlib/releases',
++ url='https://github.com/python-xlib/python-xlib',
++ license='LGPLv2+',
++
++ author='Peter Liljenberg',
++ author_email='petli@ctrl-c.liu.se',
++
+ install_requires=['six>=1.10.0'],
+ setup_requires=['setuptools-scm'],
++
+ packages=[
+ 'Xlib',
+ 'Xlib.ext',
+@@ -20,4 +28,22 @@ setup(
+ 'Xlib.support',
+ 'Xlib.xobject'
+ ],
++
++ keywords='xlib x11 x windows',
++ classifiers=[
++ 'Development Status :: 5 - Production/Stable',
++ 'Environment :: X11 Applications',
++ 'Intended Audience :: Developers',
++ 'License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)',
++ 'Operating System :: OS Independent',
++ 'Programming Language :: Python :: 2.7',
++ 'Programming Language :: Python :: 3',
++ 'Programming Language :: Python :: 3.3',
++ 'Programming Language :: Python :: 3.4',
++ 'Programming Language :: Python :: 3.5',
++ 'Programming Language :: Python :: Implementation :: CPython',
++ 'Topic :: Software Development :: Libraries :: Python Modules',
++ 'Topic :: Software Development :: Libraries',
++ 'Topic :: Software Development :: User Interfaces',
++ ],
+ )
+--
+2.22.0
diff --git a/python/python-xlib/setup.patch.gz b/python/python-xlib/setup.patch.gz
deleted file mode 100644
index ff61457796..0000000000
--- a/python/python-xlib/setup.patch.gz
+++ /dev/null
Binary files differ