summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2015-12-31 13:04:25 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-12-31 13:04:25 +0700
commitdcfa88f452d9556c60242283b64b04ea60a58fb3 (patch)
tree9404e28526c80bf9e8defc2a5cd32b06ec2a5b85 /python
parent6275f54f18ec1342865b669dbcebe7cb3ce200bd (diff)
downloadslackbuilds-dcfa88f452d9556c60242283b64b04ea60a58fb3.tar.gz
slackbuilds-dcfa88f452d9556c60242283b64b04ea60a58fb3.tar.xz
python/python-magic: Updated for version 0.4.10>
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-magic/python-magic.SlackBuild13
-rw-r--r--python/python-magic/python-magic.info6
2 files changed, 10 insertions, 9 deletions
diff --git a/python/python-magic/python-magic.SlackBuild b/python/python-magic/python-magic.SlackBuild
index 9479bd48fd..aea733d41b 100644
--- a/python/python-magic/python-magic.SlackBuild
+++ b/python/python-magic/python-magic.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-magic
-# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-magic
-VERSION=${VERSION:-0.4.6}
+VERSION=${VERSION:-0.4.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -63,6 +63,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README.md > $PKG/usr/doc/$PRGNAM-$VERSION/README.md
+cat $CWD/LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-magic/python-magic.info b/python/python-magic/python-magic.info
index 06acc27cb5..3232ab2245 100644
--- a/python/python-magic/python-magic.info
+++ b/python/python-magic/python-magic.info
@@ -1,8 +1,8 @@
PRGNAM="python-magic"
-VERSION="0.4.6"
+VERSION="0.4.10"
HOMEPAGE="https://github.com/ahupp/python-magic"
-DOWNLOAD="http://pypi.python.org/packages/source/p/python-magic/python-magic-0.4.6.tar.gz"
-MD5SUM="07e7a0fea78dd81ed609414c3484df58"
+DOWNLOAD="http://pypi.python.org/packages/source/p/python-magic/python-magic-0.4.10.tar.gz"
+MD5SUM="becc45e6b4e00d4e8a6bdf727c52bd27"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"