summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2020-05-02 16:18:18 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-05-03 08:48:46 +0700
commite142c3f2d84ad9cd9c9329e92e3e5381bb8fa35a (patch)
treec2c3c20c3b8c74749b3d7144d889d48772299e0a /python
parentf1380a88b6c5c50df0c3442e07f83dce2ded0f1b (diff)
downloadslackbuilds-e142c3f2d84ad9cd9c9329e92e3e5381bb8fa35a.tar.gz
slackbuilds-e142c3f2d84ad9cd9c9329e92e3e5381bb8fa35a.tar.xz
python/python3-openpyxl: Added (lib to read/write Excel 2010 files)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-openpyxl/README7
-rw-r--r--python/python3-openpyxl/python3-openpyxl.SlackBuild85
-rw-r--r--python/python3-openpyxl/python3-openpyxl.info10
-rw-r--r--python/python3-openpyxl/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/python3-openpyxl/README b/python/python3-openpyxl/README
new file mode 100644
index 0000000000..a01b1cb919
--- /dev/null
+++ b/python/python3-openpyxl/README
@@ -0,0 +1,7 @@
+openpyxl is a Python library to read/write Excel 2010
+xlsx/xlsm/xltx/xltm files.
+
+Optional dependencies:
+python3-defusedxml guards against various XML vulnerabilities.
+python3-pandas reads Pandas DataFrames.
+python3-pillow reads images.
diff --git a/python/python3-openpyxl/python3-openpyxl.SlackBuild b/python/python3-openpyxl/python3-openpyxl.SlackBuild
new file mode 100644
index 0000000000..549f270c18
--- /dev/null
+++ b/python/python3-openpyxl/python3-openpyxl.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for python3-openpyxl
+
+# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-openpyxl
+VERSION=${VERSION:-3.0.3}
+COMMIT=${COMMIT:-ca7b1baf75f2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=openpyxl
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCNAM-$COMMIT
+tar xvf $CWD/$VERSION.tar.bz2
+cd $SRCNAM-$SRCNAM-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py build
+python3 setup.py install --skip-build --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst *.txt doc/*.rst doc/*.txt doc/charts/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-openpyxl/python3-openpyxl.info b/python/python3-openpyxl/python3-openpyxl.info
new file mode 100644
index 0000000000..6eb84b0ee2
--- /dev/null
+++ b/python/python3-openpyxl/python3-openpyxl.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-openpyxl"
+VERSION="3.0.3"
+HOMEPAGE="https://openpyxl.readthedocs.org/"
+DOWNLOAD="https://bitbucket.org/openpyxl/openpyxl/get/3.0.3.tar.bz2"
+MD5SUM="8e1cd4bc3045f866e8890cd782f1af64"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jdcal et_xmlfile"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-openpyxl/slack-desc b/python/python3-openpyxl/slack-desc
new file mode 100644
index 0000000000..da89caf538
--- /dev/null
+++ b/python/python3-openpyxl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-openpyxl: python3-openpyxl (Python library to read/write Excel 2010 files)
+python3-openpyxl:
+python3-openpyxl: openpyxl is a Python library to read/write Excel 2010
+python3-openpyxl: xlsx/xlsm/xltx/xltm files.
+python3-openpyxl:
+python3-openpyxl:
+python3-openpyxl:
+python3-openpyxl:
+python3-openpyxl:
+python3-openpyxl:
+python3-openpyxl: