summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:12 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:23 +0700
commite177f86681d1da17a0e9a194165b50e9b11c9465 (patch)
tree4b122f91eb939e71cce3b77f6597ac15cc734467 /python
parent9747a79c32e5da245fc0e7a6fb89d5f504af658f (diff)
downloadslackbuilds-e177f86681d1da17a0e9a194165b50e9b11c9465.tar.gz
slackbuilds-e177f86681d1da17a0e9a194165b50e9b11c9465.tar.xz
python/cryptography: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/cryptography/cryptography.SlackBuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/python/cryptography/cryptography.SlackBuild b/python/cryptography/cryptography.SlackBuild
index ea66340723..62d391b63b 100644
--- a/python/cryptography/cryptography.SlackBuild
+++ b/python/cryptography/cryptography.SlackBuild
@@ -71,12 +71,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true