summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2022-04-26 04:07:43 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-30 13:51:51 +0700
commitf0cd9244112cabcaa11b13fe592b0800fcb4e7c3 (patch)
tree3fb137b1a216de4689082c82d59cee60a492bddc /python
parent1d211f98aa85d102fa3169aa2baccd740ec95d69 (diff)
downloadslackbuilds-f0cd9244112cabcaa11b13fe592b0800fcb4e7c3.tar.gz
slackbuilds-f0cd9244112cabcaa11b13fe592b0800fcb4e7c3.tar.xz
python/python3-tomlkit: Added (Style-preserving TOML library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-tomlkit/README5
-rw-r--r--python/python3-tomlkit/python3-tomlkit.SlackBuild97
-rw-r--r--python/python3-tomlkit/python3-tomlkit.info10
-rw-r--r--python/python3-tomlkit/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/python/python3-tomlkit/README b/python/python3-tomlkit/README
new file mode 100644
index 0000000000..145b57d498
--- /dev/null
+++ b/python/python3-tomlkit/README
@@ -0,0 +1,5 @@
+TOML Kit is a style-preserving TOML library for Python.
+
+It includes a parser that preserves all comments, indentations,
+whitespace and internal element ordering, and makes them accessible
+and editable via an intuitive API.
diff --git a/python/python3-tomlkit/python3-tomlkit.SlackBuild b/python/python3-tomlkit/python3-tomlkit.SlackBuild
new file mode 100644
index 0000000000..e7bbe04dc0
--- /dev/null
+++ b/python/python3-tomlkit/python3-tomlkit.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/bash
+
+# Slackware build script for python3-tomlkit
+
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-tomlkit
+VERSION=${VERSION:-0.10.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=tomlkit
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-tomlkit/python3-tomlkit.info b/python/python3-tomlkit/python3-tomlkit.info
new file mode 100644
index 0000000000..5ec6195400
--- /dev/null
+++ b/python/python3-tomlkit/python3-tomlkit.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-tomlkit"
+VERSION="0.10.2"
+HOMEPAGE="https://github.com/sdispater/tomlkit"
+DOWNLOAD="https://github.com/sdispater/tomlkit/releases/download/0.10.2/tomlkit-0.10.2.tar.gz"
+MD5SUM="308140bc03dbf2d4e4092837163bf888"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-tomlkit/slack-desc b/python/python3-tomlkit/slack-desc
new file mode 100644
index 0000000000..1929321cc3
--- /dev/null
+++ b/python/python3-tomlkit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-tomlkit: python3-tomlkit (Style-preserving TOML library)
+python3-tomlkit:
+python3-tomlkit: TOML Kit is a style-preserving TOML library for Python.
+python3-tomlkit:
+python3-tomlkit:
+python3-tomlkit:
+python3-tomlkit:
+python3-tomlkit:
+python3-tomlkit:
+python3-tomlkit:
+python3-tomlkit: