summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2020-02-16 21:01:40 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:55:20 -0500
commitfd8a792973d7f4ee0be1141c7d178e6f0df98f26 (patch)
tree553236ffdce906ee8f253d960188207f101fce56 /python
parent103342ca753b6eaa6ef1e784e3b3518a51dce8b5 (diff)
downloadslackbuilds-fd8a792973d7f4ee0be1141c7d178e6f0df98f26.tar.gz
slackbuilds-fd8a792973d7f4ee0be1141c7d178e6f0df98f26.tar.xz
python/python-future: Removed (added to Slackware).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-future/README3
-rw-r--r--python/python-future/doinst.sh3
-rw-r--r--python/python-future/python-future.SlackBuild87
-rw-r--r--python/python-future/python-future.info10
-rw-r--r--python/python-future/slack-desc19
5 files changed, 0 insertions, 122 deletions
diff --git a/python/python-future/README b/python/python-future/README
deleted file mode 100644
index 8eef8438bd..0000000000
--- a/python/python-future/README
+++ /dev/null
@@ -1,3 +0,0 @@
-python-future is the missing compatibility layer between Python 2 and
-Python 3. It allows you to use a single, clean Python 3.x-compatible
-codebase to support both Python 2 and Python 3 with minimal overhead.
diff --git a/python/python-future/doinst.sh b/python/python-future/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/python/python-future/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/python/python-future/python-future.SlackBuild b/python/python-future/python-future.SlackBuild
deleted file mode 100644
index c5534c90d6..0000000000
--- a/python/python-future/python-future.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-future
-
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-future
-SRCNAM=$(echo $PRGNAM | cut -c8-13)
-VERSION=${VERSION:-0.18.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-future/python-future.info b/python/python-future/python-future.info
deleted file mode 100644
index 32a8f29fc1..0000000000
--- a/python/python-future/python-future.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-future"
-VERSION="0.18.0"
-HOMEPAGE="https://github.com/PythonCharmers/python-future"
-DOWNLOAD="https://files.pythonhosted.org/packages/f6/85/c273089eb6efa5644c0a1382ea553554bc0d40e00a46d989ec67f123f8b5/future-0.18.0.tar.gz"
-MD5SUM="75ff140f2f609c8c0cb32e0c8f4ef78d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-future/slack-desc b/python/python-future/slack-desc
deleted file mode 100644
index f397961378..0000000000
--- a/python/python-future/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-future: python-future (Python 2/3 compatibility)
-python-future:
-python-future: python-future is the missing compatibility layer between Python 2 and
-python-future: Python 3. It allows you to use a single, clean Python 3.x-compatible
-python-future: codebase to support both Python 2 and Python 3 with minimal overhead.
-python-future:
-python-future: Homepage: https://github.com/PythonCharmers/python-future
-python-future:
-python-future:
-python-future:
-python-future: