summaryrefslogtreecommitdiffstats
path: root/system/BasiliskII
diff options
context:
space:
mode:
author ponce <matteo.bernardini@gmail.com>2012-05-28 21:39:16 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-08-21 16:23:41 -0500
commitdba403361728a1f5c11a6d833ebfb30259d39e9a (patch)
treea991f0431055b1b1a62dd8c429d46013509cfc8f /system/BasiliskII
parent93f7e669864bddcdf38103e54db3d87f6c9b1a75 (diff)
downloadslackbuilds-dba403361728a1f5c11a6d833ebfb30259d39e9a.tar.gz
slackbuilds-dba403361728a1f5c11a6d833ebfb30259d39e9a.tar.xz
system/BasiliskII: Added (68k Macintosh Emulator).
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system/BasiliskII')
-rw-r--r--system/BasiliskII/BasiliskII.SlackBuild102
-rw-r--r--system/BasiliskII/BasiliskII.info10
-rw-r--r--system/BasiliskII/README5
-rw-r--r--system/BasiliskII/doinst.sh3
-rw-r--r--system/BasiliskII/files/BasiliskII.desktop9
-rw-r--r--system/BasiliskII/files/BasiliskII.svg106
-rw-r--r--system/BasiliskII/files/fix-64bit-check.diff25
-rw-r--r--system/BasiliskII/slack-desc19
8 files changed, 279 insertions, 0 deletions
diff --git a/system/BasiliskII/BasiliskII.SlackBuild b/system/BasiliskII/BasiliskII.SlackBuild
new file mode 100644
index 0000000000..c99dfcf6ca
--- /dev/null
+++ b/system/BasiliskII/BasiliskII.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# Slackware build script for BasiliskII
+# Written by ponce <matteo.bernardini@gmail.com>
+
+PRGNAM=BasiliskII
+VERSION=${VERSION:-20120528}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="COPYING ChangeLog README TECH TODO"
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# fix building on 64bit
+if [ "$ARCH" = "x86_64" ]; then
+ patch -p1 < $CWD/files/fix-64bit-check.diff
+fi
+
+# fix a moved header with recent kernels
+sed -i "s|net/if_tun\.h|linux/if_tun.h|" src/Unix/{ether_unix.cpp,configure.ac}
+
+cd src/Unix
+NO_CONFIGURE=1 ./autogen.sh
+CPPFLAGS="-I/usr/include/readline" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --mandir=/usr/man \
+ --enable-jit-compiler \
+ --disable-vosf \
+ --enable-sdl-video=yes \
+ --enable-sdl-audio=yes \
+ --with-mon=no \
+ --with-x \
+ --host=$ARCH-slackware-linux \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+cd -
+
+install -m 0644 -D $CWD/files/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+install -m 0644 -D $CWD/files/$PRGNAM.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/BasiliskII/BasiliskII.info b/system/BasiliskII/BasiliskII.info
new file mode 100644
index 0000000000..568dbcd52a
--- /dev/null
+++ b/system/BasiliskII/BasiliskII.info
@@ -0,0 +1,10 @@
+PRGNAM="BasiliskII"
+VERSION="20120528"
+HOMEPAGE="http://basilisk.cebix.net/"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/BasiliskII-20120528.tar.xz"
+MD5SUM="f4223dab33eecfb562f2d10dda6daeec"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED=""
diff --git a/system/BasiliskII/README b/system/BasiliskII/README
new file mode 100644
index 0000000000..e0b9ef798e
--- /dev/null
+++ b/system/BasiliskII/README
@@ -0,0 +1,5 @@
+BasiliskII (68k Macintosh Emulator)
+
+Basilisk II is an Open Source 68k Macintosh emulator.
+It allows you to run 68k MacOS software on your computer, however
+still need a copy of MacOS and a Macintosh ROM image to use it.
diff --git a/system/BasiliskII/doinst.sh b/system/BasiliskII/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/system/BasiliskII/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/system/BasiliskII/files/BasiliskII.desktop b/system/BasiliskII/files/BasiliskII.desktop
new file mode 100644
index 0000000000..966b04efbf
--- /dev/null
+++ b/system/BasiliskII/files/BasiliskII.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Basilisk II
+Comment=68k Macintosh Emulator
+Exec=BasiliskII
+Icon=BasiliskII.svg
+Terminal=false
+Type=Application
+Categories=Application;Utility;
+Encoding=UTF-8
diff --git a/system/BasiliskII/files/BasiliskII.svg b/system/BasiliskII/files/BasiliskII.svg
new file mode 100644
index 0000000000..4eac158b62
--- /dev/null
+++ b/system/BasiliskII/files/BasiliskII.svg
@@ -0,0 +1,106 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="485.43735"
+ height="562.31342"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.48.2 r9819"
+ sodipodi:docname="disegno.svg">
+ <defs
+ id="defs4" />
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="0.66833139"
+ inkscape:cx="-212.4745"
+ inkscape:cy="-6.9383877"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer1"
+ showgrid="false"
+ inkscape:window-width="1648"
+ inkscape:window-height="1032"
+ inkscape:window-x="0"
+ inkscape:window-y="0"
+ inkscape:window-maximized="1"
+ fit-margin-top="5"
+ fit-margin-left="5"
+ fit-margin-right="5"
+ fit-margin-bottom="5" />
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Livello 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(-16.349841,-20.361317)">
+ <g
+ id="g3948"
+ transform="translate(1119.2053,1.4962637)">
+ <path
+ sodipodi:nodetypes="ccccc"
+ inkscape:connector-curvature="0"
+ id="path3147"
+ d="m -870.21277,158.95793 c 0,0 48.51402,-2.23911 85.83249,-41.79669 36.5721,-47.767646 28.36204,-93.296187 28.36204,-93.296187 0,0 -49.26038,2.239109 -86.57885,46.274907 -32.46234,40.60896 -27.61568,88.81797 -27.61568,88.81797 z"
+ style="fill:#61bb46;fill-opacity:1;stroke:none" />
+ <path
+ sodipodi:nodetypes="ccccccc"
+ inkscape:connector-curvature="0"
+ id="path3149"
+ d="m -1073.2253,221.65296 415.72783,0 c 5.97096,-5.97096 10.44918,-8.21006 19.40561,-11.19554 0,0 -43.99764,-58.21682 -109.71631,-58.21682 -54.48497,0 -52.97061,23.88383 -104.49173,23.88383 -51.58596,0 -49.70135,-24.6302 -108.22357,-24.6302 -65.71863,0 -112.70183,70.15873 -112.70183,70.15873 z"
+ style="fill:#61bb46;fill-opacity:1;stroke:none" />
+ <path
+ sodipodi:nodetypes="ccccc"
+ inkscape:connector-curvature="0"
+ id="path3151"
+ d="m -1073.2253,221.65296 c -10.4491,16.42013 -20.8983,50.75312 -23.8838,71.65147 l 397.81494,0 c 3.73185,-22.39108 23.88382,-59.70956 41.79669,-71.65147 z"
+ style="fill:#fdb827;fill-opacity:1;stroke:none" />
+ <path
+ sodipodi:nodetypes="ccccc"
+ inkscape:connector-curvature="0"
+ id="path3153"
+ d="m -1097.1091,292.55806 c -1.4927,23.13745 -0.7464,43.28943 2.2391,70.9051 l 403.78591,0 c -8.95643,-26.12293 -11.94192,-45.52854 -8.21007,-70.15873 z"
+ style="fill:#f5821f;fill-opacity:1;stroke:none" />
+ <path
+ sodipodi:nodetypes="cccccc"
+ inkscape:connector-curvature="0"
+ id="path3174"
+ d="m -1094.87,363.46316 404.53228,0 c 10.44917,32.09389 40.30395,55.97772 67.91962,64.18778 l -2.23911,5.97095 -450.80719,0 c -11.1955,-23.13745 -15.6737,-46.27491 -19.4056,-70.15873 z"
+ style="fill:#e03a3e;fill-opacity:1;stroke:none" />
+ <path
+ sodipodi:nodetypes="ccccc"
+ inkscape:connector-curvature="0"
+ id="path3176"
+ d="m -1076.2107,433.62189 450.80712,0 c -8.21006,24.63019 -25.37656,51.49949 -38.06484,69.41236 l -375.42388,0 c -14.181,-19.40561 -29.8548,-45.52854 -37.3184,-69.41236 z"
+ style="fill:#963d97;fill-opacity:1;stroke:none" />
+ <path
+ sodipodi:nodetypes="cccccc"
+ inkscape:connector-curvature="0"
+ id="path3178"
+ d="m -1038.8923,503.03425 375.42388,0 c 0,0 -44.78217,73.14421 -93.29619,73.14421 -41.05032,0 -47.01515,-23.88382 -92.54981,-23.88382 -47.77348,0 -54.3187,23.88382 -96.28166,23.88382 -38.87575,0 -80.60792,-47.76765 -93.29622,-73.14421 z"
+ style="fill:#009ddc;fill-opacity:1;stroke:none" />
+ </g>
+ </g>
+</svg>
diff --git a/system/BasiliskII/files/fix-64bit-check.diff b/system/BasiliskII/files/fix-64bit-check.diff
new file mode 100644
index 0000000000..e5b92cd9c0
--- /dev/null
+++ b/system/BasiliskII/files/fix-64bit-check.diff
@@ -0,0 +1,25 @@
+--- BasiliskII-20120218/src/Unix/configure.ac.orig 2012-02-24 10:18:59.744000107 +0100
++++ BasiliskII-20120218/src/Unix/configure.ac 2012-02-24 10:19:10.334991387 +0100
+@@ -110,22 +110,6 @@
+ x86_64* ) HAVE_X86_64=yes;;
+ esac
+
+-dnl Check if we should really be assuming x86_64 even if we detected HAVE_I386 above.
+-if [[ "x$HAVE_I386" = "xyes" ]]; then
+- AC_TRY_RUN([
+- int main(void) {
+- #if defined(__x86_64__)
+- return 0;
+- #else
+- return 1;
+- #endif
+- }
+- ], [
+- HAVE_I386=no
+- HAVE_X86_64=yes
+- ])
+-fi
+-
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CC_C_O
diff --git a/system/BasiliskII/slack-desc b/system/BasiliskII/slack-desc
new file mode 100644
index 0000000000..8324be383a
--- /dev/null
+++ b/system/BasiliskII/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+BasiliskII: BasiliskII (68k Macintosh Emulator)
+BasiliskII:
+BasiliskII: Basilisk II is an Open Source 68k Macintosh emulator.
+BasiliskII: It allows you to run 68k MacOS software on your computer, however
+BasiliskII: you still need a copy of MacOS and a Macintosh ROM image to use it.
+BasiliskII:
+BasiliskII: homepage: http://basilisk.cebix.net/
+BasiliskII:
+BasiliskII:
+BasiliskII:
+BasiliskII: