summaryrefslogtreecommitdiffstats
path: root/system/capstone
diff options
context:
space:
mode:
author Fernando Lopez Jr <fernando.lopezjr@gmail.com>2018-08-20 14:53:10 +0100
committer David Spencer <idlemoor@slackbuilds.org>2018-08-20 14:53:36 +0100
commit70d4edcef243a7141e5113a81e53a77d38dc8bfd (patch)
tree0b94d19336fc22a1cd70844ea97344b96cc2fa2b /system/capstone
parent3b09e4eaf59ae0b52154c1bbeaa6e6c4f606c482 (diff)
downloadslackbuilds-70d4edcef243a7141e5113a81e53a77d38dc8bfd.tar.gz
slackbuilds-70d4edcef243a7141e5113a81e53a77d38dc8bfd.tar.xz
system/capstone: Updated for version 3.0.5 (stable version).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system/capstone')
-rw-r--r--system/capstone/CMakeLists.txt.patch22
-rw-r--r--system/capstone/capstone.SlackBuild15
-rw-r--r--system/capstone/capstone.info6
3 files changed, 8 insertions, 35 deletions
diff --git a/system/capstone/CMakeLists.txt.patch b/system/capstone/CMakeLists.txt.patch
deleted file mode 100644
index 2107c99d1c..0000000000
--- a/system/capstone/CMakeLists.txt.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- CMakeLists.txt 2017-04-17 07:31:11.000000000 -0600
-+++ CMakeLists_new.txt 2017-07-31 17:02:55.478190634 +0100
-@@ -466,15 +466,15 @@
- if (CAPSTONE_BUILD_STATIC)
- install(TARGETS capstone-static
- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib)
-+ LIBRARY DESTINATION lib${LIB_SUFFIX}
-+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
- endif ()
-
- if (CAPSTONE_BUILD_SHARED)
- install(TARGETS capstone-shared
- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib)
-+ LIBRARY DESTINATION lib${LIB_SUFFIX}
-+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
- endif ()
-
- if (CAPSTONE_BUILD_SHARED)
diff --git a/system/capstone/capstone.SlackBuild b/system/capstone/capstone.SlackBuild
index 23b45342e1..fe645c81ef 100644
--- a/system/capstone/capstone.SlackBuild
+++ b/system/capstone/capstone.SlackBuild
@@ -23,8 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=capstone
-VERSION=${VERSION:-4.0_alpha5}
-SRCVER=$(echo $VERSION | tr _ -)
+VERSION=${VERSION:-3.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $TMP/$PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
-cd $PRGNAM-$SRCVER
+rm -rf $TMP/$PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -70,10 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# capstone lacks 64bit library location support for cmake. this patch
-# will re-implement it. version 4.0-alpha5
-patch -p0 --verbose < $CWD/CMakeLists.txt.patch
-
mkdir -p build
cd build
@@ -111,7 +106,7 @@ sed -e "s|%VERSION%|$VERSION|" -e "s|%LIBDIRSUFFIX%|$LIBDIRSUFFIX|" \
> $PKG/usr/share/pkgconfig/capstone.pc
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COMPILE* LICENSE* README.md TODO RELEASE_NOTES HACK.TXT ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COMPILE* LICENSE* README TODO RELEASE_NOTES HACK.TXT ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/capstone/capstone.info b/system/capstone/capstone.info
index e92d1c5d97..e79138c439 100644
--- a/system/capstone/capstone.info
+++ b/system/capstone/capstone.info
@@ -1,8 +1,8 @@
PRGNAM="capstone"
-VERSION="4.0_alpha5"
+VERSION="3.0.5"
HOMEPAGE="http://www.capstone-engine.org"
-DOWNLOAD="https://github.com/aquynh/capstone/archive/4.0-alpha5/capstone-4.0-alpha5.tar.gz"
-MD5SUM="4722b2b5e5c4bbb1c5c777a98e5f8a9e"
+DOWNLOAD="https://github.com/aquynh/capstone/archive/3.0.5/capstone-3.0.5.tar.gz"
+MD5SUM="2cd59a5a83b50fbf7663b1678bae9410"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""