summaryrefslogtreecommitdiffstats
path: root/system/disk-manager
diff options
context:
space:
mode:
author Edinaldo P. Silva <edps.mundognu@gmail.com>2015-05-24 23:30:38 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-05-31 10:36:12 +0700
commitaced7c997ce4c9e883b5ff58921d3c3edfe4040a (patch)
tree1cd88ded75519aeaca2d433c7d3eddd62fdff07c /system/disk-manager
parent731c69b44328652ffbb6b982337f38f6c1e40356 (diff)
downloadslackbuilds-aced7c997ce4c9e883b5ff58921d3c3edfe4040a.tar.gz
slackbuilds-aced7c997ce4c9e883b5ff58921d3c3edfe4040a.tar.xz
system/disk-manager: Added (simple filesystem configurator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/disk-manager')
-rw-r--r--system/disk-manager/README11
-rw-r--r--system/disk-manager/disk-manager-1.0.1-3.diff158
-rw-r--r--system/disk-manager/disk-manager.SlackBuild105
-rw-r--r--system/disk-manager/disk-manager.info10
-rw-r--r--system/disk-manager/doinst.sh13
-rw-r--r--system/disk-manager/slack-desc19
6 files changed, 316 insertions, 0 deletions
diff --git a/system/disk-manager/README b/system/disk-manager/README
new file mode 100644
index 0000000000..1e061ca035
--- /dev/null
+++ b/system/disk-manager/README
@@ -0,0 +1,11 @@
+disk-manager (simple filesystem configurator)
+
+Disk Manager is a tool to manage filesystems, partitions, and NTFS write mode.
+
+Disk manager is a simple filesystem configurator that allows you to:
+
+* Automatically detect new partitions at startup.
+* Fully manage configuration of filesystem.
+* Enable/disable write support for NTFS (needs ntfs-3g installed).
+
+This require: ktsuss, xfsudo or gksu for authenticated method.
diff --git a/system/disk-manager/disk-manager-1.0.1-3.diff b/system/disk-manager/disk-manager-1.0.1-3.diff
new file mode 100644
index 0000000000..780260cec9
--- /dev/null
+++ b/system/disk-manager/disk-manager-1.0.1-3.diff
@@ -0,0 +1,158 @@
+diff -Naur disk-manager-1.0.1~/configure disk-manager-1.0.1/configure
+--- disk-manager-1.0.1~/configure 2009-01-18 13:05:41.000000000 -0600
++++ disk-manager-1.0.1/configure 2009-01-18 13:05:45.000000000 -0600
+@@ -752,6 +752,7 @@
+ INTLTOOL_MSGMERGE
+ INTLTOOL_XGETTEXT
+ ALL_LINGUAS
++PYTHON2_7
+ PYTHON2_4
+ PYTHON
+ PYTHON2_5
+@@ -6370,6 +6371,91 @@
+
+
+ if test -z "$PYTHON"; then
++ # Extract the first word of "python2.7", so it can be a program name with args.
++set dummy python2.7; ac_word=$2
++{ echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
++if test "${ac_cv_path_PYTHON2_7+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ case $PYTHON2_7 in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_PYTHON2_7="$PYTHON2_7" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ ac_cv_path_PYTHON2_7="$as_dir/$ac_word$ac_exec_ext"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++IFS=$as_save_IFS
++
++ ;;
++esac
++fi
++PYTHON2_7=$ac_cv_path_PYTHON2_7
++if test -n "$PYTHON2_7"; then
++ { echo "$as_me:$LINENO: result: $PYTHON2_7" >&5
++echo "${ECHO_T}$PYTHON2_7" >&6; }
++else
++ { echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6; }
++fi
++
++
++ else
++ PYTHON2_7="$PYTHON"
++ fi
++
++ PYTHON="$PYTHON2_7"
++
++
++ if test -n "$PYTHON"; then
++
++
++ { echo "$as_me:$LINENO: checking whether $PYTHON version is >= 2.7.0" >&5
++echo $ECHO_N "checking whether $PYTHON version is >= 2.7.0... $ECHO_C" >&6; }
++ prog="import sys, string
++# split strings by '.' and convert to numeric. Append some zeros
++# because we need at least 4 digits for the hex conversion.
++minver = map(int, string.split('2.7.0', '.')) + [0, 0, 0]
++minverhex = 0
++for i in xrange(0, 4): minverhex = (minverhex << 8) + minver[i]
++sys.exit(sys.hexversion < minverhex)"
++ if { echo "$as_me:$LINENO: $PYTHON -c "$prog"" >&5
++ ($PYTHON -c "$prog") >&5 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; then
++ { echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6; }
++else
++ { echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6; }; PYTHON=""
++fi
++
++
++
++ fi
++
++ if test -z "$PYTHON"; then
++
++ PYTHON="$_python_save"
++
++
++ _python_save="$PYTHON"
++
++
++
++ if test -z "$PYTHON"; then
+ # Extract the first word of "python2.4", so it can be a program name with args.
+ set dummy python2.4; ac_word=$2
+ { echo "$as_me:$LINENO: checking for $ac_word" >&5
+@@ -6608,6 +6694,7 @@
+
+
+ fi
++ fi
+
+
+
+diff -Naur disk-manager-1.0.1~/Makefile.in disk-manager-1.0.1/Makefile.in
+--- disk-manager-1.0.1~/Makefile.in 2009-01-18 13:05:41.000000000 -0600
++++ disk-manager-1.0.1/Makefile.in 2009-01-18 13:05:45.000000000 -0600
+@@ -581,6 +581,8 @@
+ info-am:
+
+ install-data-am:
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps
++ ln -sf ../icons/hicolor/scalable/apps/@PACKAGE@.svg $(DESTDIR)$(datadir)/pixmaps
+
+ install-exec-am: install-binSCRIPTS install-sbinSCRIPTS
+
+diff -Naur disk-manager-1.0.1~/data/disk-manager-check.desktop.in.in disk-manager-1.0.1/data/disk-manager-check.desktop.in.in
+--- disk-manager-1.0.1~/data/disk-manager-check.desktop.in.in 2009-01-18 13:05:41.000000000 -0600
++++ disk-manager-1.0.1/data/disk-manager-check.desktop.in.in 2009-01-18 13:06:16.000000000 -0600
+@@ -1,12 +1,9 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+-Name=Aucun nom
+-_Name=Disk manager
++_Name=Disk Manager
+ _Comment=Check for new partitions
+ Icon=disk-manager
+ Exec=@prefix@/bin/disk-manager --check
+ Terminal=false
+ Type=Application
+-Categories=
+-GenericName[fr_FR]=
++Categories=System;Filesystem;
+diff -Naur disk-manager-1.0.1~/data/disk-manager.desktop.in.in disk-manager-1.0.1/data/disk-manager.desktop.in.in
+--- disk-manager-1.0.1~/data/disk-manager.desktop.in.in 2009-01-18 13:05:41.000000000 -0600
++++ disk-manager-1.0.1/data/disk-manager.desktop.in.in 2009-01-18 13:05:45.000000000 -0600
+@@ -1,12 +1,9 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+-Name=Aucun nom
+ _Name=Disk Manager
+ _Comment=Manage filesystem configuration
+ Icon=disk-manager
+ Exec=@prefix@@EXEC_PATH@/disk-manager-root
+ Terminal=false
+ Type=Application
+-Categories=Application;System;Settings
+-GenericName[fr_FR]=
++Categories=System;Filesystem;
diff --git a/system/disk-manager/disk-manager.SlackBuild b/system/disk-manager/disk-manager.SlackBuild
new file mode 100644
index 0000000000..d17c9a4f5f
--- /dev/null
+++ b/system/disk-manager/disk-manager.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+# Slackware build script for disk-manager.
+
+# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=disk-manager
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/disk-manager-1.0.1-3.diff
+mkdir -p $PKG/etc/hal/fdi/policy
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README TODO"
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/disk-manager/disk-manager.info b/system/disk-manager/disk-manager.info
new file mode 100644
index 0000000000..35166018e8
--- /dev/null
+++ b/system/disk-manager/disk-manager.info
@@ -0,0 +1,10 @@
+PRGNAM="disk-manager"
+VERSION="1.0.1"
+HOMEPAGE="http://flomertens.free.fr/disk-manager/"
+DOWNLOAD="http://flomertens.free.fr/disk-manager/download/source/disk-manager-1.0.1.tar.gz"
+MD5SUM="904f47f2b2d51871fa4d0ee6f9051921"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/system/disk-manager/doinst.sh b/system/disk-manager/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/system/disk-manager/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/disk-manager/slack-desc b/system/disk-manager/slack-desc
new file mode 100644
index 0000000000..399abef667
--- /dev/null
+++ b/system/disk-manager/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+disk-manager: disk-manager (simple filesystem configurator)
+disk-manager:
+disk-manager: Disk Manager is a tool to manage filesystems, partitions, and
+disk-manager: NTFS write mode.
+disk-manager:
+disk-manager: Home page: http://flomertens.free.fr/disk-manager/
+disk-manager:
+disk-manager:
+disk-manager:
+disk-manager:
+disk-manager: