summaryrefslogtreecommitdiffstats
path: root/system/driconf/driconf.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-10 12:43:17 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-10 12:43:17 -0400
commitfd2a455e664c29e2d58ac630130dc8dec66d69a6 (patch)
tree4773c20498d40806f95205676291789d96ec11e1 /system/driconf/driconf.SlackBuild
parentd5a8e8774a3131981a072b7dfcccf5aa435bb51f (diff)
downloadslackbuilds-fd2a455e664c29e2d58ac630130dc8dec66d69a6.tar.gz
slackbuilds-fd2a455e664c29e2d58ac630130dc8dec66d69a6.tar.xz
system/driconf: Fix icon path, add doinst.sh.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'system/driconf/driconf.SlackBuild')
-rw-r--r--system/driconf/driconf.SlackBuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/system/driconf/driconf.SlackBuild b/system/driconf/driconf.SlackBuild
index f2554fcb04..f2e0c03551 100644
--- a/system/driconf/driconf.SlackBuild
+++ b/system/driconf/driconf.SlackBuild
@@ -23,11 +23,15 @@
# Thanks to James Powell for the .desktop file.
+# 20220410 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - install icon where the .desktop file expects to find it.
+# - add doinst.sh (need because we have a .desktop).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=driconf
VERSION=${VERSION:-0.9.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +77,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
cat $CWD/driconf-0.9.1-2.diff | patch --verbose -p1
@@ -86,8 +87,7 @@ python setup.py install --root=$PKG
mkdir -p $PKG/usr/share/{applications,driconf}
cp $CWD/driconf.desktop $PKG/usr/share/applications/driconf.desktop
-cp -a driconf-icon.png $PKG/usr/share/applications/driconf-icon.png
-
+cp -a driconf-icon.png $PKG/usr/share/driconf/driconf-icon.png
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -98,6 +98,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE