summaryrefslogtreecommitdiffstats
path: root/system/gkrellm-volume
diff options
context:
space:
mode:
author Paul Wisehart <wise@lupulin.net>2010-05-11 15:18:37 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 15:18:37 +0200
commit4a1010775fc803757be03ad4affae301e5e2f364 (patch)
treeecf48966a2de04693b031979f3921e4cb77faa0b /system/gkrellm-volume
parentf5de26e6f50459ed5afe0f8ef1438f4b5213f440 (diff)
downloadslackbuilds-4a1010775fc803757be03ad4affae301e5e2f364.tar.gz
slackbuilds-4a1010775fc803757be03ad4affae301e5e2f364.tar.xz
system/gkrellm-volume: Initial import
Diffstat (limited to 'system/gkrellm-volume')
-rw-r--r--system/gkrellm-volume/Makefile.diff54
-rw-r--r--system/gkrellm-volume/README6
-rw-r--r--system/gkrellm-volume/gkrellm-volume.SlackBuild63
-rw-r--r--system/gkrellm-volume/gkrellm-volume.info8
-rw-r--r--system/gkrellm-volume/slack-desc9
5 files changed, 140 insertions, 0 deletions
diff --git a/system/gkrellm-volume/Makefile.diff b/system/gkrellm-volume/Makefile.diff
new file mode 100644
index 0000000000..d93b0202e7
--- /dev/null
+++ b/system/gkrellm-volume/Makefile.diff
@@ -0,0 +1,54 @@
+diff -Naur gkrellm-volume.orig/Makefile gkrellm-volume/Makefile
+--- gkrellm-volume.orig/Makefile 2004-08-19 15:07:27.000000000 -0500
++++ gkrellm-volume/Makefile 2006-10-29 21:57:34.000000000 -0600
+@@ -1,15 +1,15 @@
+ # Makefile for GKrellM volume plugin
+
+ PACKAGE ?= gkrellm-volume
+-LOCALEDIR ?= /usr/local/share/locale
++LOCALEDIR ?= /usr/share/locale
+
+ FLAGS += -DPACKAGE="\"$(PACKAGE)\""
+ export PACKAGE LOCALEDIR
+
+ GTK_CONFIG = pkg-config gtk+-2.0
+
+-PLUGIN_DIR ?= /usr/local/lib/gkrellm2/plugins
+-GKRELLM_INCLUDE = -I/usr/local/include
++PLUGIN_DIR ?= /usr/lib/gkrellm2/plugins
++GKRELLM_INCLUDE = -I/usr/include
+
+ GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
+ GTK_LIB = `$(GTK_CONFIG) --libs`
+@@ -33,6 +33,7 @@
+
+ CC = gcc $(CFLAGS) $(FLAGS)
+
++MKDIR = mkdir -p
+ INSTALL = install -c
+ INSTALL_PROGRAM = $(INSTALL) -s
+
+@@ -48,7 +49,8 @@
+
+ install:
+ (cd po && ${MAKE} install)
+- $(INSTALL_PROGRAM) volume.so $(PLUGIN_DIR)
++ $(MKDIR) $(DESTDIR)$(PLUGIN_DIR)
++ $(INSTALL_PROGRAM) volume.so $(DESTDIR)/$(PLUGIN_DIR)
+
+ %.c.o: %.c
+
+diff -Naur gkrellm-volume.orig/po/Makefile gkrellm-volume/po/Makefile
+--- gkrellm-volume.orig/po/Makefile 2004-08-19 15:07:27.000000000 -0500
++++ gkrellm-volume/po/Makefile 2006-10-29 21:55:33.000000000 -0600
+@@ -14,8 +14,8 @@
+ install:
+ $(MAKE) all
+ for f in *.mo ; do mkdir -p \
+- $(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES ; \
+- cp $$f $(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES/$(PACKAGE).mo ; done
++ $(DESTDIR)$(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES ; \
++ cp $$f $(DESTDIR)$(INSTALL_PREFIX)$(LOCALEDIR)/`basename $$f .mo`/LC_MESSAGES/$(PACKAGE).mo ; done
+
+ %.mo: %.po
+ $(MSGFMT) -f -v -o $@ $<
diff --git a/system/gkrellm-volume/README b/system/gkrellm-volume/README
new file mode 100644
index 0000000000..ebb6dc9931
--- /dev/null
+++ b/system/gkrellm-volume/README
@@ -0,0 +1,6 @@
+gkrellm-volume is a plugin for gkrellm 2.0 that lets you control your
+sound mixer..
+
+This plugin also supports gkrellm's plugin theming possibilities; it's even
+included in the default gkrellm theme :) The keyword for the plugin is
+"volume".
diff --git a/system/gkrellm-volume/gkrellm-volume.SlackBuild b/system/gkrellm-volume/gkrellm-volume.SlackBuild
new file mode 100644
index 0000000000..d67fc3a2ed
--- /dev/null
+++ b/system/gkrellm-volume/gkrellm-volume.SlackBuild
@@ -0,0 +1,63 @@
+#!/bin/sh
+
+### gkrellm-volume.SlackBuild ###
+
+# Slackware build script for gkrellm-volume 2.1.13
+# Copyright (C) 2006 paul wisehart wise@lupulin.net
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# Modifed by the SlackBuilds.org project
+
+PKGNAME=gkrellm-volume
+VERSION=2.1.13
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PKGNAME
+OUTPUT=${OUTPUT:-/tmp} # Final location of package
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PKGNAME-$VERSION
+tar -xvzf $CWD/$PKGNAME-$VERSION.tar.gz || exit 1
+cd $PKGNAME || exit 1
+chown -R root:root .
+chmod -R a-s,u+w,go+r-w .
+
+# Patch the Makefile and po/Makefile to support DESTDIR
+cat $CWD/Makefile.diff | patch -p1 --verbose || exit 1
+
+make enable_nls=1 enable_alsa=1 || exit 1
+make enable_nls=1 enable_alsa=1 install DESTDIR=$PKG || exit 1
+
+# Strip the .so file
+strip --strip-unneeded $PKG/usr/lib/gkrellm2/plugins/volume.so
+
+mkdir -p $PKG/usr/doc/$PKGNAME-$VERSION
+cp -a COPYRIGHT Changelog README THEMING $PKG/usr/doc/$PKGNAME-$VERSION
+cp -a po/README $PKG/usr/doc/$PKGNAME-$VERSION/README.po
+cat $CWD/$PKGNAME.SlackBuild > $PKG/usr/doc/$PKGNAME-$VERSION/$PKGNAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/gkrellm-volume/gkrellm-volume.info b/system/gkrellm-volume/gkrellm-volume.info
new file mode 100644
index 0000000000..2031d8a632
--- /dev/null
+++ b/system/gkrellm-volume/gkrellm-volume.info
@@ -0,0 +1,8 @@
+PRGNAM="gkrellm-volume"
+VERSION="2.1.13"
+HOMEPAGE="http://gkrellm.luon.net/volume.phtml"
+DOWNLOAD="http://gkrellm.luon.net/files/gkrellm-volume-2.1.13.tar.gz"
+MD5SUM="d9f4c36d7fdf9c9f755c99f742b573c4"
+MAINTAINER="paul wisehart"
+EMAIL="wise@lupulin.net"
+APPROVED="robw810"
diff --git a/system/gkrellm-volume/slack-desc b/system/gkrellm-volume/slack-desc
new file mode 100644
index 0000000000..896fb37f58
--- /dev/null
+++ b/system/gkrellm-volume/slack-desc
@@ -0,0 +1,9 @@
+gkrellm-volume: gkrellm-volume plugin
+gkrellm-volume:
+gkrellm-volume: A plugin which allows you to control the sound mixer devices
+gkrellm-volume: of your choice.
+gkrellm-volume:
+gkrellm-volume: Author: Sjoerd Simons <sjoerd@luon.net>
+gkrellm-volume:
+gkrellm-volume:
+gkrellm-volume: