summaryrefslogtreecommitdiffstats
path: root/system/gnome-commander/gnome-commander.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2012-09-28 21:05:36 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-28 21:26:58 -0500
commit7c9af8a39a75cc6bf516ef0e08767cd958afacdc (patch)
tree6b1acfd05c169fb55015fb504e6ef0787b79f7bd /system/gnome-commander/gnome-commander.SlackBuild
parent2fadf73222ca4c5df26f425bae6ebe203a4cfc69 (diff)
downloadslackbuilds-7c9af8a39a75cc6bf516ef0e08767cd958afacdc.tar.gz
slackbuilds-7c9af8a39a75cc6bf516ef0e08767cd958afacdc.tar.xz
system/gnome-commander: Updated for version 20120801_2f83e80.
Added a patch for the new poppler, and another for gcc-4.7.x Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'system/gnome-commander/gnome-commander.SlackBuild')
-rw-r--r--system/gnome-commander/gnome-commander.SlackBuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/system/gnome-commander/gnome-commander.SlackBuild b/system/gnome-commander/gnome-commander.SlackBuild
index 3499974caa..d08463338a 100644
--- a/system/gnome-commander/gnome-commander.SlackBuild
+++ b/system/gnome-commander/gnome-commander.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for <gnome-commander>
PRGNAM=gnome-commander
-VERSION=${VERSION:-1.2.8.2}
+VERSION=${VERSION:-20120801_2f83e80}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -35,13 +35,15 @@ else
LIBDIRSUFFIX=""
fi
+#PYTHON_ROOT=/usr/lib$LIBDIRSUFFIX/python2.7/config
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -50,26 +52,34 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix for the new poppler
+patch -p1 < $CWD/gnome-commander-poppler020.patch
+
+# Another for gcc-4.7.x
+patch -p1 < $CWD/gcc47.patch
+
+# This helps autodetecting pyton
+sed -i "s|PY_EXEC_PREFIX/lib|PY_EXEC_PREFIX/lib${LIBDIRSUFFIX}|" configure.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-./configure \
+./autogen.sh \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
+ --disable-scrollkeeper \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \